• My site was down and the hosting company told me during a live chat that the “document root path was incorrectly set in the wordfence file and user.ini file” and said it “the plugin wordfence that caused the issue” and happens when a plugin updates.

    They updated the path and the site is back up, but the plugin updated 2 weeks ago, not recently. I wondered if this happens or it’s truly a server issue on their end.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey @delawaregrad,

    If the file path was incorrect, this could definitely happen. But it doesn’t dynamically adjust itself, it’s set when you first set up your Wordfence Firewall. Have you recently migrated the site?

    Please let me know.



    Thread Starter delawaregrad


    The site has been as is for over a year. I didn’t think this could be related to the plugin.

    Last month, the WP temp folder disappeared and the hosting couldn’t explain why that happened either. I felt like this was on their end and thought it was weird to blame Wordfence.




    This same situation happened to me last week and it took my hosting company a few days to fix it.

    This is what they said:

    “Path for wordfence-waf.php file is not updated. I have updated the path in .user.ini which fixed the issue.”

    We haven’t changed anything on the site for the past year, and hadn’t updated any plugins in the past couple weeks. Any idea what happened and how to prevent it in the future?

    On a related note, I logged in to update the site and had a notice to Optimize Wordfence Firewall. It had this message:

    To make your site as secure as possible, the Wordfence Web Application Firewall is designed to run via a PHP setting called auto_prepend_file, which ensures it runs before any potentially vulnerable code runs. This PHP setting is currently in use, and is including this file:

    If you don’t recognize this file, please contact us on the WordPress support forums before proceeding.

    You can proceed with the installation and we will include this from within our wordfence-waf.php file which should maintain compatibility with your site, or you can opt to override the existing PHP setting.

    This is the file that had the bad path in the users.ini file. How should I proceed?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘500 server error’ is closed to new replies.