Support » Fixing WordPress » 500 internall server error when I am (loged in admin)

  • makecake

    (@mohammedays)


    Hello there,
    I have been having 500 internal server error for about 3 months. nowadays it is occurring more often. I am so tired of it and cannot solve it.:

    deactivated all the plugin ( it worked fine)
    then I started activating one by one, and I noticed that I only have like 3 plugin left that my theme requires. when I kept the plugin activated I get the 500 internal server error, and it log me out ( admin) then I started browsing the site while I am not loged in and it works fine.

    My observation of this tells me that when I log in as the admin I have the error, when I log out the error goes away.

    does anyone have an idea on how to solve this?

    thank you for the support.

Viewing 15 replies - 1 through 15 (of 29 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Which plugin(s)? What are the errors?

    makecake

    (@mohammedays)

    @sterndata
    I only have fusion builder and fusion core plugin activated now. I’m using Avada theme and they are required.

    I noticed when I am not logged in there is no error. But when I’m logged in as admin I get the error on many links including the admin bar on top.

    My host is Bluehost and they told me the error is from google analytics. I was using MonsterInsights and contacted MonsterInsights and sent them the error. They said that “ It seems your server had an issue copying one of the files of our plugin on an update.” I deactivated and deleted the plugin 5 days ago. And I still get the error. Cleared all cashing as well.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Try reinstalling, activating, then deleting that plugin. Maybe the original deletion did not work properly.

    makecake

    (@mohammedays)

    I did install and activated then delete. nothing has changed.

    I noticed when I am loged in as an admin, i get the errors. I created another user and loged in with it and still have the error.

    I used to have bbpress installed and I deleted it, and I found some users associated with it and deleted them.

    also, I notice that when I am loged in, it loges me out by itself.

    all the plugin now are deactivated including the core one that avada requires.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    What are the errors?

    makecake

    (@mohammedays)

    500 internal server error and loges me out of admin.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Errors like this are logged. Check the error log on your server. If you can’t find the log, please contact your host.

    Meantime, enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there. https://wordpress.org/support/article/debugging-in-wordpress/

    makecake

    (@mohammedays)

    these are some ( recent ones)

    PHP Fatal error: require(): Failed opening required ‘/home1/xxxxxx/public_html/wp-includes/version.php’ (include_path=’.:/opt/cpanel/ea-php70/root/usr/share/pear’) in /home1/xxxxxx/public_html/wp-settings.php on line 24

    PHP Warning: require(/home1/xxxxxx/public_html/wp-includes/version.php): failed to open stream: No such file or directory in /home1/xxxxxx/public_html/wp-settings.php on line 24

    PHP Warning: require(/home1/xxxxxx/public_html/wp-includes/version.php): failed to open stream: No such file or directory in /home1/xxxxxx/public_html/wp-settings.php on line 24

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Please do not “modlook” your post. There’s nothing here requiring moderator attention.

    It looks like you’re missing some files or they’re improperly secured. In your root directory (public_html), do you see these files?

    .htaccess
    index.php
    license.txt
    readme.html
    wp-activate.php
    wp-admin
    wp-blog-header.php
    wp-comments-post.php
    wp-config.php
    wp-config-sample.php
    wp-content
    wp-cron.php
    wp-includes
    wp-links-opml.php
    wp-load.php
    wp-login.php
    wp-mail.php
    wp-settings.php
    wp-signup.php
    wp-trackback.php
    xmlrpc.php
    
    makecake

    (@mohammedays)

    I do not know what you mean by “modlook”

    Yes I see all the files in the list. thanks for your attention.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    You clicked the “report this topic” button. Anyhow, are all the permissions and ownership the same on those files?

    makecake

    (@mohammedays)

    I am sorry I was not aware if that.

    folders are 0755
    files are 0644
    wp-config.php 0600

    can you please tell me how to check the ownership?

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    For ownership, please check with your host. You might try changing permissions to 775 for directories and 664 for files.

    makecake

    (@mohammedays)

    from FTP owner/group the all have the same numbers. 1397/1395
    so changing 0755 to 775 and 0644 to 664?

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    change the permissions, not the ownership

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘500 internall server error when I am (loged in admin)’ is closed to new replies.