Support » Plugin: Yoast SEO » 500 internal server errors when posting posts, only since Yoast SEO 55

  • Resolved Sabinooo

    (@sabinooo)


    Howdy!

    On my blog, submitting blog posts *works* (the blog posts go live) but the tab in which I am editing and publishing them becomes, after a very long loading time doing nothing, ends up in a “500 internal server error” message.

    Some context, maybe?

    Yoast SEO 5.01, latest stable WordPress 4.8.

    Apache’s error log, two post submitting attempts:

    [Fri Jul 07 03:17:00 2017] [warn] [client 86.208.230.179] mod_fcgid: read data timeout in 91 seconds, referer: (mywebsite's URL)/wp-admin/post.php?post=86582&action=edit
    [Fri Jul 07 03:17:00 2017] [error] [client 86.208.230.179] Premature end of script headers: post.php, referer: (mywebsite's URL)/wp-admin/post.php?post=86582&action=edit
    [Fri Jul 07 03:18:51 2017] [warn] [client 86.208.230.179] mod_fcgid: read data timeout in 91 seconds, referer: (mywebsite's URL)/wp-admin/post-new.php?wp-post-new-reload=true
    [Fri Jul 07 03:18:51 2017] [error] [client 86.208.230.179] Premature end of script headers: post.php, referer: (mywebsite's URL)/wp-admin/post-new.php?wp-post-new-reload=true

    No slow query registered where the rest of them are registered in my server, so we didn’t have an abnormal slow query related to posting the posts.

    Before that, after Yoast updated itself to 5.0, I had the same error as in https://wordpress.org/support/topic/problems-counting-links/
    The engine took forever to index my ten years of posts (over 13k blog posts), and in the end, well, it seemed to believe it couldn’t create the tables even though the tables were created. I could confirm the link counting worked, it was displayed in the related columns in wordpress’s /wp-admin/edit.php list of posts. (It didn’t count links in the posts that were saved as scheduled before Yoast 5, side note.)

    My php’s timeout delay is 90 seconds, it should have been enough to do whatever database ops were required, right?
    And now, well, I can post blog posts, it works, but I end up with this 500 internal server error in the admin section. Not super friendly.

    If you need more details, sure, it’s possible to send PMs in the WP forums? Or else, give me an email addy. Otherwise, good luck fixing it 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • Michael

    (@anotherjpeg)

    Experiencing the exact same thing. Seems like whatever is going on with the link counting maxes out database connections when posting and brings it all down.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    That sounds like a plugin or theme conflict. Can you try and gather as much information for us? Please perform the following:

    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.

    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new issue on GitHub for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Michael

    (@anotherjpeg)

    Disabling the Yoast SEO plugin fixes the issue. Does seem to appear something related to the 5.0.1 update.

    Reactivating the plugin, update or publish a post produces the following errors and warnings.

    [warn] [client 162.158.126.42] mod_fcgid: stderr: WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND  comment_type != 'webhook_delivery'   ORDER BY comment_date_gmt DESC LIMIT 1' at line 1 for query SELECT comments.* FROM comments   AND  comment_type != 'webhook_delivery'   ORDER BY comment_date_gmt DESC LIMIT 10 made by require('wp-blog-header.php'), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts
    
    [warn] [client xxx.xxx.xxx.xx] mod_fcgid: read data timeout in 120 seconds, referer: /wp-admin/post.php?post=43978&action=edit
    [error] [client xxx.xxx.xxx.xx] Premature end of script headers: post.php, referer: /wp-admin/post.php?post=43978&action=edit
    • This reply was modified 2 years ago by  Michael.
    Plugin Support marcanor

    (@marcanor)

    Thank you for opening the issue on Github. For future reference you can find this issue here: https://github.com/Yoast/wordpress-seo/issues/7411

    Thomas Anderson

    (@celsiusanderson)

    Manually download the 4.9 and moving back to it solved the issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘500 internal server errors when posting posts, only since Yoast SEO 55’ is closed to new replies.