WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 500 internal server error while upgrading to 3.5

[Resolved] 500 internal server error while upgrading to 3.5

  • Hello everybody,
    unfortunately tonight I tried to automatically update my wordpress from 3.4.1 to 3.5. Apparently the upgrading was unsuccessfull and now I get a 500 internal server error on any page of my website.
    The website is http://www.benecrippa.com and I have no clue about what might have caused it.
    Can anybody give some help or at least helping me figuring out the cause of this?
    Thank you so much,
    b

Viewing 15 replies - 1 through 15 (of 18 total)
  • I’m getting the same issue. I was also upgrading from 3.4.1 to 3.5. Except only my back end is causing the issue. It says:

    The website encountered an error while retrieving http://personalbrandingpros.com/wp-admin/. It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this webpage later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    It appears to be the same issue.

    Rename your .htaccess file to old.htaccess and see if that lets you in?

    If so, then see if the .htaccess is just this and it works: http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29

    Hello Ipstenu,
    thank you for your answer.
    Done as you suggested, and just updated the .htaccess as suggested on the link, but nothing working yet….

    I even tried to restore all the wordpress files from a backup and I still get the 500 error on any page.

    Hi,
    same problem. During update to 3.5:
    500 Internal Server Error
    Please help

    The Error Log show:
    End of script output before headers: index.php
    AH01215: suexec policy violation: see suexec log for more details
    Please Help
    Thanks

    I uploaded a backup copy of:
    – root files
    – wp-admin directory
    – wp-includes directory
    Now is working, but what i have to do to update 3.5?
    Thanks

    Moderator Dion Hulse

    @dd32

    Lead Developer

    AH01215: suexec policy violation: see suexec log for more details

    @mascor: Do you have access to the logs generated by PHP? or more specifically, the suexec logs?
    You may need to ask your web host for the details, it sounds like the security modules installed on your server are out of date, and are blocking WordPress accidentally.

    Hi,
    thanks for your help.
    I asked for “suexec log” to my web host and I’m waiting a response.

    Please can you tell me what are “security modules installed on your server”?

    Thanks
    Bye

    I have the same error, when i tried upgrading it to 3.5. But how do i rename my .htacces ? I’m not a big whizzkid so can anybody explain me that?

    Hello everybody, I contacted my host which solved the problem by adding this code line to my file wp-settings.php:
    require( ABSPATH . WPINC . '/class-wp-embed.php' );

    Now my website is up and running.
    Cheers

    Hi there, I’ve got the same problem after trying to upgrade to the latest WP version, I think 3.5, my site http://www.saboi.co.za
    The .htaccess file was completely blank and I’ve put in the following code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Now I only get a blank page when visiting my site

    I added the .htaccess file and the line of code in wp-settings.php. Still no go.

    My daughter’s blog on 3.4.1 is running fine on the same server my 3.5 upgrade is giving an error 500.

    Can I roll my blog back to 3.4.1, or will that throw errors on a 3.5 version of the database?

    My blog: zzzptm.com

    I’ve run into the same issue. I’ve tried .htaccess, deactivating plugins, checked for the code line in wp-settings and I’ve still got nothing.

    Since this one is marked “resolved”, perhaps the WP support folks are ignoring it. I’ll see if there’s another active thread or start my own…

    AH01215: suexec policy violation: see suexec log for more details

    Just got this error log message after upgrading from 3.4.1 to 3.5.1. The problem comes from file permissions set to 0644, after changing this to 0755 everything worked fine.

    The problem seems to be with hostings using suexec to manage the permissions of files and folders. More info on this thread (in italian): http://www.wpitaly.it/2008/12/05/utenti-aruba-linux-aggiornamento-automatico-worpdpress-27/

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] 500 internal server error while upgrading to 3.5’ is closed to new replies.
Skip to toolbar