Support » Plugin: W3 Total Cache » 500 Internal Server Error when saving settings – but they are saved

  • I’m having multiple problems with W3TC. It’s a first time set up. I followed instructions and it seems to install fine, but there are a few occasions in which W3 Total Cache throws errors at me:

    1. When I save some settings, I get a 500 Internal Server error. I mean – right after I hit save (not “update successfully” message). Settings are saved, and the config file is updated, so it’s not a file permission issue. Something tries to execute and fails.
    For instance, enabling Page Cache or changing to any method causes this to happen. Changing Browser Cache (enable/disable) does NOT cause this to happen. Clearing cache DOES cause this to happen. All upon saving.

    2. Even once set, as saving does work, W3TC doesn’t seem to be caching at all.

    Clearly, there’s something up with my server setup. On my local workspace it works fine but on air there’s something up.

    Is there a general outline of server requirements anywhere? Libraries that need be installed, folder permissions, etc. This is not outlined in details during installation. I’m trying to figure out what I’m doing wrong.

    It’s worth mentioning I tried finding the error in apache error log but it won’t appear. Also tried disabling all kinds of plugins. Locally though, they are all enabled just the same as they are on server side, and as I mentioned locally W3TC doesn’t throw these 500 errors.

    Additional information: WP 3.4.2, WordPress multisite enabled

    Any ideas are welcome, highly appreciate it

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘500 Internal Server Error when saving settings – but they are saved’ is closed to new replies.