Support » Plugin: WP Ajaxify Comments » 500 internal server error when posting empty comment

Viewing 6 replies - 1 through 6 (of 6 total)
  • I am getting the same thing. The error is not displaying in a pop up. I can see it in firebug but nothing shows on the page.

    Any recommendations?

    Ahhh I just solved it.

    I had to set Z-Index to a super big number because the error pops up at the top but we have a fixed header that scrolls.

    After setting it to 999999999999999999999999 which is way larger than the largest valid number. It works.

    Try that and look for the little error message in red at the top of your browser.

    Plugin Author janjonas


    Hi, hi smartwebdev,
    WordPress returns a status code 500 (Internal Server Error) by design if the comment form was not filled out correctly (like empty comment or invalid e-mail address). So this is not a problem.
    Could you please send me a link where I can reproduce the problem?

    Setting the z-index (default is 1000) to a higher value could be necessary (depending on your theme or customizings). Nevertheless, I would not recommend to set the z-index to value larger than 2147483647 (

    Hope this helps…

    Hi janjonas,

    I sent you a mail to mail at janjonas dot net. Please have a look.
    Thanks, Tamas

    Plugin Author janjonas


    Thanks, login data works. Posting comments works too. What is the exact problem?

    As mentioned above the (red) request that returns a 500 HTTP Status code in the console isn’t a problem. WordPress returns a 500er error be design.

    Best regards,

    that was the problem, but you asked for a link to check it, so you’ve got one 😀

    If it is by design, then I let it be… thanks, cheers

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘500 internal server error when posting empty comment’ is closed to new replies.