WordPress.org

Forums

500 Internal Server error when files were temporarily moved (8 posts)

  1. fatfingers
    Member
    Posted 9 years ago #

    Aaargh...I recently moved my /wp/ folder into another created temporary one...(along with the index.php file) then moved them back to their original places.

    The blog URL is: http://www.thepogostick.com

    Now I keep coming up with 500 Internal Server error...have checked the permissions as all should be okay and are in their original places from where they were before.

    Anybody able to help? :(

    Thanks heaps in advance.

  2. fatfingers
    Member
    Posted 9 years ago #

    Anybody? :*( Have no idea how to fix this.

    Is anyone able to help out with permissions?

    I can still get to my Dashboard, though main URL http://www.thepogostick.com isn't working...

    Through FTP, In my www folder it has as its permissions: lrwxrwxrwx (not sure what the 'l' is, as it usually has 'd' before the other folders if at 777) the WordPress folder has its permissions set at 777

    Anybody :'( am happy to give my details to someone if they're able to help through Filezilla or something...

    :( back to trying to make it work...

  3. tomhanna
    Member
    Posted 9 years ago #

    Try setting permissions to 755. Also, you may want to delete the .htaccess file, which I suspect will fix problem (save a copy first). Then you just need to debug the .htaccess file line by line.

  4. fatfingers
    Member
    Posted 9 years ago #

    drat...tried that, though didn't work :*\ not to worry...will keep trying...thanks for your response...

  5. moshu
    Member
    Posted 9 years ago #

    Whenever you move the WP folder around you need to change the URI(s) in the Options > General. Did you do that every time?

  6. fatfingers
    Member
    Posted 9 years ago #

    Thanks, moshu...yup...I did...and can (thankfully) still get access to the Dashboard. Everything's supposedly back in its original place now (I copied all of the files to my hard-drive first before I moved) though still not working...(have re-worded the 500 Error on the main URL).

    Blergh...I'm sure it's something simple, either that or it's totally screwed. (Am happy to donate if someone can take a look?) am sure it's just some permissions gone astray...

    Hmm...a new file has just appeared (.cpanel-ducache) in my root directory...is that something that's supposed to be there?

    *sigh* sorry...*wry look*

  7. travelman
    Member
    Posted 9 years ago #

    hello fatfingers, what's happened to thepogostick.com??? have you fat fingered it again? ;) i visited your site back in dec and many times since. some great stories and witty sarcasm about thailand! bring it back!

  8. Samuel B
    moderator
    Posted 9 years ago #

    I would delete my .htaccess and create a new one in Notepad.
    Open Notepad - hit space bar once - save file.
    Upload it to your WP root and rename it .htaccess. CHMOD 666.
    Update your permalinks - this writes to your .htaccess.
    Change CHMOD to 644 on .htaccess for security.

Topic Closed

This topic has been closed to new replies.

About this Topic