Support » Plugin: Jetpack by WordPress.com » 500 Internal Server Error when activating Jetpack plugin

  • Resolved DJChupa13

    (@djchupa13)



    I have no other plugins installed.

    When I activate the Jetpack plugin (latest version), I immediately get the Internal Server Error message. The message persists throughout all of WP-Admin, and through all of my site’s pages except for the home page (probably caching).

    Deleting the plugin folder (thus deactivating the plugin) resolves the issue immediately.

    I have deleted and manually re-added the Jetpack plugin folder multiple times, trying a couple of different scenarios with the PHP alloc numbers. Nothing has worked so far. I’m currently set to 128M alloc, with a max of 256M.

    This problem persists after a fresh manual install of WordPress. I’m using GoDaddy (Plesk) for hosting. Their error logs are way over my head, but if you’d like me to post today’s logs, I certainly can.

    This problem has persisted over several versions of Jetpack. By the way, I cannot install Jetpack using the auto-install tool. When I click the blue “install” button at the bottom of the page (after entering my site’s URL) it queues up the plugin install. However, when it attempts to communicate with my WP site, it idles out into the same 500 Internal Server Error page. The plugin folder is created and populated successfully (I can see it through FTP) so I’m guessing it errors out when attempting to activate the plugin, just as it would manually.

    I’ve been fighting this issue for nearly a year. SOS! Please send help!

Viewing 13 replies - 16 through 28 (of 28 total)
  • <?php
    /**
    * The base configuration for WordPress
    *
    * The wp-config.php creation script uses this file during the
    * installation. You don’t have to use the web site, you can
    * copy this file to “wp-config.php” and fill in the values.
    *
    * This file contains the following configurations:
    *
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    *
    * @link https://codex.wordpress.org/Editing_wp-config.php
    *
    * @package WordPress
    */

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘[removed from public forum]’);

    /** MySQL database username */
    define(‘DB_USER’, ‘[removed from public forum]’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘[removed from public forum]’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘[removed from public forum]’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    [removed from public forum]
    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‘[removed from public forum]’;

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    *
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    *
    * @link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define(‘WP_DEBUG’, false);

    if ( WP_DEBUG ) {

    @error_reporting( E_ALL );
    @ini_set( ‘log_errors’, true );
    @ini_set( ‘log_errors_max_len’, ‘0’ );

    define( ‘WP_DEBUG_LOG’, true );
    define( ‘WP_DEBUG_DISPLAY’, false );
    define( ‘CONCATENATE_SCRIPTS’, false );
    define( ‘SAVEQUERIES’, true );

    }

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    define( ‘WP_ALLOW_MULTISITE’, true );

    define (‘FS_METHOD’, ‘direct’);
    ?>

    • This reply was modified 1 year, 11 months ago by  James Huff. Reason: removed credentials from public forum

    If this is NOT on a local WAMP|MAMP|LAMP install then change your passwords right away as you just let the world know what they are!

    Also, he wanted your debug.log file, not your wp-config.php file.

    • This reply was modified 1 year, 11 months ago by  Tim Berneman. Reason: Add the bit about the debug.log file

    Hooooo I am s*****t. Thanks @tbernerman.

    I cant get the debug.log file. help where may find it?

    Read the first post by @jeherve as he provided the code to put in your wp-config.php file that will create the debug.log file. Also, there may be clues in your error.log file which is usually in the root folder of your site.

    Thanks, this thread helped me resolve the same issue. My server was not running PHP 5.6.

    I am having the same issues with jetpack as like djchupa13
    Exactly same
    When i activate it. I am unable to go to my wp admin but i can see plugin activated when i visit my site but the whats the purpose of activating it when im unable to go to my wp admin ?

    I have also deleted the jetpack folder and reinstalled a fresh copy several times but no luck.

    @civilengineerspk

    The solution to this problem as @djchupa13 found out was the PHP/MySQL version. According to the minimum specs for running WordPress you must be using PHP v5.6 or greater and MySQL v5.6 or greater as per this link: https://wordpress.org/about/requirements/

    You can check your versions in your Plesk/CPanel account. MySQL version can be found in CPanel->Databases->phpMyAdmin and on the right side (usually) under the “Database Server” group.

    The same issue for me now.

    @anzilone

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    Contact Support

    @anzilone are you running PHP v5.6 or greater?

    Thanks, this thread helped me resolve the same issue. My server was not running PHP 5.6. (2)

Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘500 Internal Server Error when activating Jetpack plugin’ is closed to new replies.