Support » Plugin: Jetpack by WordPress.com » 500 Internal Server Error when activating Jetpack plugin

  • Resolved DJChupa13

    (@djchupa13)


    I have no other plugins installed.

    When I activate the Jetpack plugin (latest version), I immediately get the Internal Server Error message. The message persists throughout all of WP-Admin, and through all of my site’s pages except for the home page (probably caching).

    Deleting the plugin folder (thus deactivating the plugin) resolves the issue immediately.

    I have deleted and manually re-added the Jetpack plugin folder multiple times, trying a couple of different scenarios with the PHP alloc numbers. Nothing has worked so far. I’m currently set to 128M alloc, with a max of 256M.

    This problem persists after a fresh manual install of WordPress. I’m using GoDaddy (Plesk) for hosting. Their error logs are way over my head, but if you’d like me to post today’s logs, I certainly can.

    This problem has persisted over several versions of Jetpack. By the way, I cannot install Jetpack using the auto-install tool. When I click the blue “install” button at the bottom of the page (after entering my site’s URL) it queues up the plugin install. However, when it attempts to communicate with my WP site, it idles out into the same 500 Internal Server Error page. The plugin folder is created and populated successfully (I can see it through FTP) so I’m guessing it errors out when attempting to activate the plugin, just as it would manually.

    I’ve been fighting this issue for nearly a year. SOS! Please send help!

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you add the following to your site’s wp-config.php file?

    
    define( 'WP_DEBUG', true );
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define( 'WP_DEBUG_DISPLAY', false );
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }
    

    If your site’s wp-config.php file already includes a line that says define( 'WP_DEBUG', false );, you’ll need to remove it.

    Once you’ve done so, try to install the plugin again by going to Plugins > Add New, and search for Jetpack. Then, once you get the 500 error, check the wp-content/debug.log file for errors, and paste the results here. You can then replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Thanks!

    Neat little trick. I actually errored out in a different way this time. Using the install method you described (Plugins > Add New > Search for Jetpack > hit install button), I instead was redirected back to the “Add Plugins” page with this error message inline:

    Installation failed: 500 Internal Server Error <!--[if lte IE 6]><![endif]--> Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error. More information about this error may be available in the server error log. Web Server at nathanabshire.com <!-- - Unfortunately, Microsoft has added a clever new - "feature" to Internet Explorer. If the text of - an error's message is "too small", specifically - less than 512 bytes, Internet Explorer returns - its own error message. You can turn that off, - but it's pretty tricky to find switch called - "smart error messages". That means, of course, - that short error messages are censored by default. - IIS always returns error messages that are long - enough to make Internet Explorer happy. The - workaround is pretty simple: pad the error - message with a big comment like this to push it - over the five hundred and twelve bytes minimum. - Of course, that's exactly what you're reading - right now. -->

    So…same error, different presentation (probably won’t matter much). Here’s the debug.log contents:

    [03-Nov-2016 22:29:33 UTC] PHP Warning:  require_once(G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack/sync/class.jetpack-sync-actions.php): failed to open stream: No such file or directory in G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack\jetpack.php on line 51
    [03-Nov-2016 22:29:33 UTC] PHP Fatal error:  require_once(): Failed opening required 'G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack/sync/class.jetpack-sync-actions.php' (include_path='.;.\includes;.\pear') in G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack\jetpack.php on line 51
    [03-Nov-2016 22:29:36 UTC] PHP Warning:  require_once(G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack/sync/class.jetpack-sync-actions.php): failed to open stream: No such file or directory in G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack\jetpack.php on line 51
    [03-Nov-2016 22:29:36 UTC] PHP Fatal error:  require_once(): Failed opening required 'G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack/sync/class.jetpack-sync-actions.php' (include_path='.;.\includes;.\pear') in G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack\jetpack.php on line 51
    [03-Nov-2016 22:29:36 UTC] PHP Warning:  require_once(G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack/sync/class.jetpack-sync-actions.php): failed to open stream: No such file or directory in G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack\jetpack.php on line 51
    [03-Nov-2016 22:29:36 UTC] PHP Fatal error:  require_once(): Failed opening required 'G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack/sync/class.jetpack-sync-actions.php' (include_path='.;.\includes;.\pear') in G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack\jetpack.php on line 51

    It looks like you’re running this locally via WAMP/MAMP/LAMP and JetPack does get wonky in that scenario. You can try this setting in your WP-CONFIG.PHP file:

    define( ‘JETPACK_DEV_DEBUG’, true );

    Good Luck!

    • This reply was modified 3 years, 7 months ago by Tim Berneman.

    Hey Tim, I’m actually hosting this with GoDaddy (Plesk), so I’m not in a local hosting situation. I decided to give your solution a try anyways, but unfortunately, it did not change anything. Thanks anyways!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    PHP Fatal error: require_once(): Failed opening required 'G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack/sync/class.jetpack-sync-actions.php' (include_path='.;.\includes;.\pear') in G:\PleskVhosts\nathanabshire.com\httpdocs\wp-content\plugins\jetpack\jetpack.php on line 51

    It appears that some of the files in your Jetpack installation are missing. Could you try to log in to your site via FTP or Plesk, delete the existing Jetpack plugin folder, and reinstall the plugin manually as explained here:
    http://codex.wordpress.org/Managing_Plugins#Manual_Plugin_Installation

    You’ll find the Jetpack plugin folder here:

    
    wp-content
       plugins
         jetpack - DELETE THIS FOLDER
    

    If you’re not sure how to do this, you can ask your hosting company for help. They should also have documentation explaining how to edit or remove files from your site using FTP or a File Manager in your admin panel.

    Let me know how it goes.

    He’s already tried that @jeremy as he said in his original post. He’s even started from scratch and reinstalled WordPress and then Jetpack with the same results. It has to be a server issue, either in the version of PHP or MySQL or the settings for one of those.

    That’s correct, thanks Tim.

    I’ll be opening a support ticket with my host shortly. Maybe they can give me some insight. In the time being, are there any other suggestions?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    My bad, sorry, I missed that part of your original post! Thanks for pointing it out @tberneman!

    @djchupa13 Can you look for this file in your Jetpack directory?

    wp-content/plugins/jetpack/sync/class.jetpack-sync-actions.php

    Do you see it there?

    Yes, it’s definitely there. Even fetched another copy of Jetpack and re-uploaded just to make sure the file wasn’t damaged, but no changes.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That’s interesting. Would you mind contacting us via this form, and mention this thread? I’d like to run more tests on your site with you, to get to the bottom of this.

    Thanks!

    I really want to say thanks to both of you for helping me this much.

    I have identified the problem. It’s my host, as we expected.

    Under Plesk hosting, my PHP version is 5.4, and mySQL is 5.5.
    This does not meet the requirements for WordPress.

    Switching from Plesk hosting to cPanel should resolve my issue, so I’m considering doing that. GoDaddy is helping me out with the switch, refunding the Plesk Hosting and switching me over to a cPanel economy plan instead.

    I’ll write back once the switch takes place. Again, thanks!

    Hey @jeherve also I am having the same problem like for @djchupa13. Once I activated the plugins
    it writing the message down here. My site is hosted by ikoula and I am using Plesk. (WWW.reportage.cd)
    Thanks for your feedback

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @baroyal Could you try to follow the recommendations @djchupa13 posted above? If switching to cPanel doesn’t help, could you follow the instructions I posted at the top of the thread to enable Debug and find out more about the errors?

    Thanks!

    Hi, @jeherve. I did all steps. now the plugins can be installed but when I activate it I got the following message.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Web Server at vmheb49018.ikoula.com

    @jeherve, I need this plugin, I am thinking even to go pro on. I never realise how it’s important.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you copy the contents of your wp-content/debug.log file, and paste them here or send them to us via this contact form?

    Thanks!

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘500 Internal Server Error when activating Jetpack plugin’ is closed to new replies.