Support » Fixing WordPress » 500 Internal Server Error – Updating / Adding Plugins

  • Resolved patocka


    Hey WordPress Gurus,

    I’m currently hitting a 500 Internal Server Error when trying to update or add plugins via Dashboard. The site still runs and accessing the dashboard doesn’t crash anything, I only receive the error when I try to update or add plugins.

    Here’s my stack: Running WordPress 3.5 with Thesis 1.8.

    Thinking that this is probably a plugin issue, I disabled ALL of the plugins via the GUI dashboard interface, went down and re-activated each one manually in order to isolate the issue, and then tried to update legacy versions of plugins with no luck.

    Any guidance would be great.

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi


    Forum Moderator

    Have you tried:

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of your current version of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    Thanks for the prompt response esmi.

    Per your advice:

    Switched over to the 2012 default theme, attempted updates, and still experienced the issue.

    Reset the plugins folder by renaming plugins to plugins.hold via FTP. Logged out, logged back in. Reverted change. Issue persists.

    Backed up entire directory. Downloaded a fresh version of wordpress files, deleted old wordpress directory and re-installed the files with the legacy version of wp-content. Also transferred over the legacy wp-config.php. This allowed me to access the update plugins menu from the toolbar at the top of the screen (which wasn’t capable before) but once I selected the plugins to update I received the server error again, only this time the entire screen didn’t white out with the message, it just showed up in the frame of the Update Plugins view.

    Now whenever I click on anything in Dashboard I get the following message: Briefly unavailable for scheduled maintenance. Check back in a minute. Same thing comes up when I try to access my site URL. Trying to access admin login, it 404’s.

    Ok, after waiting a while the site is back up. I can get into admin. But the problem remains where I get the error, and the 500 Internal Server error is the same as before. The difference now is that I have the following at the top of the screen:

    An automated WordPress update has failed to complete – please attempt the update again now.

    Click the hyperlink to update and *boom* 500 Internal Server error.



    Forum Moderator

    OK – what version of WordPress did you upload?




    Forum Moderator

    Can you access your site’s error logs?

    Well, after recreating the issue multiple times by trying to run the following:



    I’ve accessed the error log via FTP and this is literally the only value that’s returned in the file after 40 min of intentional failure generation.

    [Tue Jan 15 13:40:24 2013] [error] [client] File does not exist: /var/chroot/home/content/p/a/t/patocka1868/html/robots.txt

    Leads me to wonder why the 500 server errors aren’t registering? Am I looking in the right place?



    Forum Moderator

    You seem to be looking in the right placer but you’re correct in that all of the 500 errors should also be in there. Try asking your hosts for assistance. Perhaps you’re picking up the wrong error log?

    The only other error log is completely empty. I’m going to kick this into my hosts inbox to see what they come up with.

    Stay tuned.

    esmi, question…where is the error log entry located? If your answer is the dashboard, where exactly. The website I am dealing with is
    It’s been down for a few days. 500 server errors are a bit too common. For some reason, it’s up and running today, knock-on-wood. The original website author is stepping away and now I’m trying to figure out exactly what the problem really is. I’ve opened a work order at GoDaddy which is the domain’s server. No response from them at all, yet. 22 hrs. old. The previuos website maker thinks it’s an .htaccess issue.
    Not sure about that either…so, I’d like to find, explore all the error log info. Could you help please?




    Forum Moderator

    @jameslomasney: It is impolite to interrupt another poster’s ongoing thread with a question of your own. It causes significant problems for the forum’s volunteers and prevents us from being able to track issues by topic. Please post your own topic.

    Update: Still waiting on my host to give me some legitimate service. They said they can’t recreate the issue. I’m still seeing it on my end. Likely going to escalate to a phone call today.

    In the meantime enjoy an extended 48 hr error log. Still with no 500 error?

    [Tue Jan 15 13:40:24 2013] [error] [client] File does not exist: /var/chroot/home/content/p/a/t/patocka1868/html/robots.txt

    [Tue Jan 15 18:58:31 2013] [error] [client] File does not exist: /var/chroot/home/content/p/a/t/patocka1868/html/robots.txt

    [Tue Jan 15 23:01:18 2013] [warn] [client] mod_fcgid: read data timeout in 40 seconds

    [Tue Jan 15 23:01:18 2013] [warn] [client] (110)Connection timed out: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

    [Tue Jan 15 23:12:45 2013] [error] [client] File does not exist: /var/chroot/home/content/p/a/t/patocka1868/html/robots.txt

    [Wed Jan 16 04:58:06 2013] [warn] [client] mod_fcgid: read data timeout in 40 seconds

    [Wed Jan 16 04:58:06 2013] [error] [client] Premature end of script headers: wp-cron.php

    [Wed Jan 16 23:32:24 2013] [error] [client] File does not exist: /var/chroot/home/content/p/a/t/patocka1868/html/robots.txt

    [Thu Jan 17 07:28:58 2013] [warn] [client] mod_fcgid: read data timeout in 40 seconds

    [Thu Jan 17 07:28:58 2013] [error] [client] Premature end of script headers: wp-cron.php

    Well, after a weekend of going back and forth with my hosting service and not finding anything on their end, I logged in today and attempted the plugin updates. And lo and behold, without changing anything outside of what was discussed in this thread – things proceeded without error.

    I have no idea how or why this happened. Go figure.

    Thanks for your help in troubleshooting regardless esmi. Cheers.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘500 Internal Server Error – Updating / Adding Plugins’ is closed to new replies.