Support » Fixing WordPress » 500 Internal Server Error (Still an issue … someone help please)

  • cristalynn84

    (@cristalynn84)


    I previously posted this issue …

    “cristalynn84 (@cristalynn84)
    1 week ago
    I am receiving an 500 Internal Server Error when I click on both of the “pages” I have created so far. Newbie to this editing stuff so go east on my with the lingo. Thank you to any assistance in advance!”

    I then received this response from a moderator ….
    t-p (@t-p)
    1 week ago
    The page you need help with generates internal server errors (error 500). internal server errors are often caused by plugin or theme function conflicts, so if you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the default theme for your version of WordPress to rule-out a theme-specific issue. If you don’t have access to your admin panel, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue.

    If that does not resolve the issue, it’s possible that a .htaccess rule could be the source of the problem. To check for this, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your SFTP or FTP client to view invisible files.

    If you weren’t able to resolve the issue by either resetting your plugins and theme or renaming your .htaccess file, we may be able to help, but we’ll need a more detailed error message. Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error again, note the date and time, then immediately check your server error log for any errors that occurred during that time period. If you don’t have access to your server error log, ask your hosting provider to look for you.

    I tried my best to do what he suggested and this is what I got …
    cristalynn84 (@cristalynn84)
    6 days ago
    Reply to @t-p :

    Let me start from the top of your reply …

    How do I know if have access to my admin panel? And are you referring to an admin panel through BlueHost or WordPress? I have to assume WordPress? When I am in my “WordPress Tools” from the top horizontal menu provided on BlueHost, and I click on “Plugins”, I am able to turn my plugins on and off, I tried turning them all off and I still received the error when viewing my profile and trying to click on these “pages” I have created. I have no since turned them all back on again just in case. I have yet to really understand what these plugins that were already there (I didn’t download them) actually do for my website.

    I then switched my theme back to the original theme provided, which was “Twenty Seventeen” and that Theme does not display “pages” like the Theme I’m trying to use does. That theme just incase it matters is “Juliet”. I do have one other Theme downloaded and it’s “Mailard” … I switched to that and that did show my “pages” and I still received the same error when clicking on my “pages” link. So it can’t be the “Juliet” theme specifically, right?

    When I tried to attempt your third possible solution I was able to get in to my “File Manager” through Bluehost, but then it asked me if I wanted to see my “Home Directory”, “Web Root” or “Document Root for” with a drop down menu where I select my domain. I went to the “Home Directory first which looked like an email inbox screen and saw nothing that was titled .htaccess … I then tried “Web Root”, it looked the same as described above but I still didn’t see anything titled .htaccess . I am getting the feeling I am completely missing something here.

    …. And I’ve heard nothing back from that moderator or anyone else.

    Is someone able to continue helping me troubleshoot this issue.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi, cristalynn84, & welcome back. First, thanks for the detailed explanation. I’m afraid at this point I have more questions than answers, but let’s see if we can’t get to the bottom of all this.

    First, could you please tell us whether or not you purchased an SSL certificate? If not, did you choose to activate a free global SSL? Also, when you installed WordPress, did you choose the http:// or the https:// option?

    I ask this because when I visit the site’s primary address &/or login address, it works, but obviously the pages don’t & I’m thinking it may have something to do w/https being chosen when no SSL certificate is present.

    can you please turn on debugging mode from wp-config.php?

    cristalynn84

    (@cristalynn84)

    @abletec

    Thank you for responding to me!!

    Regarding the SSL .. when I go in to my Bluehost CPanel, and click on SSL, it says right at the top of the page, “You have already purchased a certificate for this domain.” and then next to that it has a drop down menu and reads “Install SSL on” and in the drop down menu my domain is there … so does this mean I just need to install the SSL?

    When I installed WordPress I was using the assistance of Bluehost and their support team so I’m not sure which I chose, http:// or https:// … is there a way for me to look somewhere and find out?

    I don’t mind your questions! I will warn you that I am horrible with some lingo yet and very very much a beginner at this so dumbing it down is helpful! Ha! But when given good instructions I can do just about anything!

    Let me know where this information leaves us. And again, I really appreciate your help!!

    cristalynn84

    (@cristalynn84)

    @soumanta

    How do I turn off debugging? And what does doing so, do?

    “Regarding the SSL .. when I go in to my Bluehost CPanel, and click on SSL, it says right at the top of the page, “You have already purchased a certificate for this domain.” and then next to that it has a drop down menu and reads “Install SSL on” and in the drop down menu my domain is there … so does this mean I just need to install the SSL?”

    That’s what it sounds like to me, cristalynn84.

    “When I installed WordPress I was using the assistance of Bluehost and their support team so I’m not sure which I chose, http:// or https:// … is there a way for me to look somewhere and find out?”

    Tell you what, cristalynn84-let’s install the SSL first & see where we end up. I’d also like to know precisely where WordPress was installed, ie, in the webroot folder or in a subfolder like wordpress or wp, but it appears to me at this point that it’s installed in the root. Please try installing the SSL, as I said, & let’s see where we are at that point.

    I understand you’re not real comfortable w/the tech stuff, so I’m trying to keep this as simple as possible. The problem is it may take longer, but I think taking things 1 step at a time will end up being the most successful strategy in the long run. Just hang in. We’ll get it resolved.

    cristalynn84

    (@cristalynn84)

    @abletec

    Seriously. You rock! For getting back to me so quickly and already declaring your patience and dedication to this!! Thank you!

    So, I went to “Install” the SSL and it appears as though it is indeed already installed. When I clicked, it brought me to a page that reads ….

    “You already have an SSL certificate installed.

    You can test if your SSL certificate is working properly by going to any working page on your site and replacing the “http://” at the front of your domain name in the address bar with “https://”. Example: http://www.olivenosh.com/ changes to https://www.olivenosh.com/

    When I go to my page using http:// it is the default “New WordPress Site Coming Soon” page. When I go to my page using https:// it is my site and I received the Internal 500 Server Error when clicking on my “pages”.

    So now knowing this, what’s next ya think?

    Thank you again!

    cristalynn84, that was helpful. We’re going to need to look at the files on your site. To do this, we’ll either need to use Bluehost’s file manager, which is found in your control panel, or an FTP client like Filezilla. For help w/Bluehost’s file manager, you can look at:
    https://my.bluehost.com/hosting/help/file_manager

    We’re looking in your web root, which is public_html or www (they’re identical), & we’re looking for a file called index.html or index.htm. If not, then we’re looking for files called home.htm/html, or perhaps default.htm/html. Please rename this file by putting a 1 at the end. Now please try to access your site.

    cristalynn84

    (@cristalynn84)

    @abletec

    Jackie! I thought I’d lost you, but the notification that you had replied wound up in my Junk Mail somehow!

    Ok, so … I found my file manager and when in there I see collapsible menus on the left and then in the middle about 5 folders and then lots of files that begin with wp-XXX … I did find one called default.html … never found anything with index.htm/html or home.htm/html … I did find once called index.php? … Either way, I changed the one titled default.html to default.html1 and that didn’t work. So just for the sake of being sure I tried all avenues, I went ahead and added the 1 after the word “default” incase that’s what you meant (default1.html) And neither worked. Also, I would like to note that the “Size” of this file called default.html is 0 bytes … not sure if that matters any? And it says the “File Type” is text/html.

    Am I missing something here? Or did I do it correctly and this just isn’t our fix?

    Thank you again!! I appreciate your help!!

    Hey, cristalynn84, I thought you got disgusted w/me & gave up. Glad to see you back. Seems like I’m always ending up in someone’s junk folder. :(.

    Can we please see your .htaccess file? When you’re in your file manager, be sure to check ‘view hidden files’ or similar.

    If you don’t have a .htaccess file, please log into your WordPress dashboard & go to ‘Settings > Permalinks’. Set the permalink structure to your preference–I personally like ‘post name’, but that’s all up to you. Don’t forget to save your changes after you’re done. Then go back into your file manager, & your .htaccess file should be there.

    Check your junk/spam folder regularly. I get sad staying in those lol.

    cristalynn84

    (@cristalynn84)

    @abletec

    Morning Jackie! No, I was not disgusted with you at all!!

    However, I’m freaking out! I can’t get to my WordPress Dashboard at all today. I tried going back in to file manager through bluehost to see if I did or didn’t change back that default.html file and I can’t find it. When I click to log in to my wordpress Dashboard through bluehost it says there is an HTTP ERROR 500 and that the page isn’t working.

    Oh man … Help! In the meantime I’m going to try and get in touch with Bluehost to see if they can help any.

    Thank you!

    cristalynn84, we *really* need your .htaccess file. Your domain does work if you go to https://www.olivenosh.com/index.php. You may log in either by using your ‘admin login’ link or by typing a /wp-login.php like: https://www.olivenosh.com/index.php/wp-login.php. Please set your permalinks as I instructed in my last post.

    cristalynn84

    (@cristalynn84)

    @abletec

    Update!! It’s fixed. Sounds like it was a default plugin issue. Ok … going back to your resolution following the renaming of that default.html file ….

    So I tried searching for the .htaccess filen in my file manager, and when I did that it gave me a big long list of folders and files. The folders consist of titles like “old”, “Olive Nosh” (which is the name of my site), “wp-admin”, “wp-content” and “wp-includes” and then files are mostly files that start with “wp-” and different variations of endings. The file types says they are all “text/x-generic” – I’m not sure what that means.

    So, then I went to “Settings” in my Dashboard and navigated to “Permalink Settings” where I find a list of “Common Settings” and little white buttons to select which one I want to use. “Custom Structure” is currently selected and looks like this …

    https://www.olivenosh.com (and then a white box where it appears I can type whatever I want in there – but it currently reads) /’/%year%/%monthnum%/%day%/%postname%/’

    What does this mean??

    Thank you as always! Talk Soon!

    cristalynn84, Permalinks are how your posts are reached. So if you had a post named hello, then your permalink, w/that structure in place, would look like:
    https://www.olivenosh.com/2017/10/20/hello. I personally suggest you check the 1 that says ‘post name’, & get a permalink like https://www.olivenosch.com/hello. Those words surrounded by % signs are called variables, (kind of like high school algebra where you dealt w/x & y). They can be substituted for actual parts of the post information, as noted above w/the year, month, & day name. Does that help?

    cristalynn84

    (@cristalynn84)

    @abletec

    Got it! I’m starting to catch on I think … So I selected “Post Name” as my Permalink structure. Saved and went back in, aaaand ….

    IT WORKS!!!

    YAY!! Thank you thank you!!

    So cristalin84, I’m still not sure we’ve got the pages to work. When you go into your WordPress dashboard, thence to ‘Settings > Reading’, what have you set your front page to, ie, recent posts or a static page? A static page is what you find on most typical websites, whereas your recent posts is like a blog. If you’ve set it to recent posts, please try publishing a test post & see if it replaces the ‘coming soon’ site.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘500 Internal Server Error (Still an issue … someone help please)’ is closed to new replies.