Support » Plugin: Reusable Content & Text Blocks by Loomisoft » 500 internal server error on WPML

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Loomisoft


    Hi @lienkhuong.

    I know we tentatively tested it with WPML and it seemed to work and I know at least one other user who runs it with WPML but I’d like us to see if we can resolve this for you.

    The issue might actually be a conflict with another plugin.

    As a test, would you be able to switch off the other plugins … one at a time … then activate our plugin, deactivate it and then reactive the other plugin. Then carry on till all your plugins have been tested.

    Would you mind letting me know how that pans out?



    • This reply was modified 2 years, 12 months ago by Loomisoft.

    Sorry but I have the same issue

    I use Avada with these plugins:

    Admin Menu Editor
    Akismet Anti-Spam
    Fusion Builder
    Fusion Builder Before/After Element
    Fusion Core
    Pixel Cat Lite
    Slide Anything – Responsive Content / HTML Slider and Carousel
    SOGO Add Script Header Footer
    WP Gallery Custom Links
    WP Hide Plugin Updates and Warnings
    WPML Multilingual CMS
    WPML String Translation
    WPML Translation Management
    Yoast SEO

    I disabled all the plugins except your plugin, WPML and fusion plugins and 500 error still exists. I added the shortcode [ls_content_block id=”53″] with Fusion Page Builders elements through widget area for my footer.

    I think the problem is in multilingual widget area which supports language switcher here: and shortcodes which generate different ID for translated content block, ex. [ls_content_block id=”53″] for main language and [ls_content_block id=”10078″] for second one.

    • This reply was modified 2 years, 11 months ago by Fostik.
    • This reply was modified 2 years, 11 months ago by Fostik.
    Plugin Author Loomisoft


    Hi @fostik.

    Thanks for contacting and clarifying so we can track down and fix the problem.

    We’ll test it out here … in the meantime:

    (a) Does the error occur if you use the slug instead of the id?
    (b) Are you able to provide any excerpts from your server’s error log?



    Plugin Author Loomisoft


    Hi Fostik

    We have a pre-release version that needs testing in the exact environment you have … would you like a link to the zip file so you can test and let us know the outcome before we release it?

    Best regards,


    Plugin Author Loomisoft


    Hi @fostik

    Happy 2018.

    Not having heard from you, we decided to hold off our amended release and look into the issue some more and try and recreate the issue you were having with the exact plugins you were running.

    Searching to see if anyone else has had this type of problem before and also looking into the WPML related code trying to see what may be causing the errors, I really am not convinced the issue is specifically to do with our plugin.

    The error (looking at you error logs) is specifically generated out of the Composer module in WPML. Looking at this link:

    I suspect somewhere else in your configuration another version of Composer is being run (our plugin does not use it). It may also be that you were not running the very latest versions of the WPML sub-plugins.

    I have to say these are just stabs in the dark on our part as we have really not been able to recreate the issue at this end running our plugin alongside Avada theme, the Fusion plugins and WPML.

    Please let us know how you are getting on.

    Best regards,




    Do you have the updated release?

    We encountered this problem also with the latest version of WPML.


    Have you guys found a solution? I have this error too. And both are premium theme and plugin. They should work properly.


    I have the same problem (with WPML returning an internal 500 server error).

    I solved the problem when I commented on the function flush_rewrite_rules() in ls_cb_main plugin class, into the register_post() function.

    When this function is called, with a non-default language selected, WordPress overwrites .htaccess and changes some rules with the prefix of the actual language.

    Another solution is setting the only read permission for the .htaccess file (444)

    You can read more information at (There is also another solution)

    I also wanted to make a request to @loomisoft to be able to solve this in a future version (and thank you very much for this powerful plugin!) šŸ˜‰

    Hope that helps

    Best regards,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘500 internal server error on WPML’ is closed to new replies.