WordPress.org

Forums

Duplicator
[resolved] 500 Internal Server Error on GoDaddy (4 posts)

  1. Pablo @ vDevices
    Member
    Posted 1 year ago #

    Greetings:

    I'm having difficulty creating a package on Go Daddy's Deluxe Linux shared hosting. I keep getting the following:

    Server Response
    AJAX Response Duplicator.Pack.Create
    duration: 120.212 secs
    code: 500
    status: Internal Server Error
    response:

    My php5.ini file is as follows:

    cgi.fix_pathinfo = 1

    session.save_path = /tmp

    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 300
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

    memory_limit = 256M
    post_max_size = 256M
    file_uploads = On
    upload_max_filesize = 256M

    extension="apc.so"
    apc.enabled=1
    apc.shm_segments=1
    apc.shm_size=64M
    apc.ttl=7200
    apc.user_ttl=7200
    apc.num_files_hint=1024
    apc.enable_cli=1

    I have a feeling that the process is timing out b/c the tail of the Duplicator log file reads, as follows:

    STARTING PACKAGE BUILD
    ADDED=>SQL: /path/to/my/wp-snapshots/[a bunch of random #s]_20130903_mysite_database.sql
    BUILDING FILE LIST
    FILE LIST COMPLETE: 5.8565 sec.
    FILE LIST STATS: Dirs 164 | Files 1939 | Links 0 |

    PACKAGE INFO: ZipArchive Object
    (
    [status] => 0
    [statusSys] => 0
    [numFiles] => 2104
    [filename] => /path/to/my/wp-snapshots/[a bunch of random #s]_20130903_mysite_package.zip
    [comment] =>
    )

    CREATING PACKAGE

    Notice how the log just cuts off @ "CREATING PACKAGE?" Any ideas on what needs tweaking?

    http://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Pablo ,

    Here is a helpful section on the FAQ page:
    -> Browse to: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: "3. Troubleshoot => Timeout Issues"

    You may also check that Apache isn't set to timeout at 120 seconds...

    Hope that helps...

  3. Pablo @ vDevices
    Member
    Posted 1 year ago #

    @lifeinthegrid,

    Thanks for the reply. So, in reviewing section 3. Troubleshoot => Timeout Issues, I tried the following:

    • added max_execution_time 0 to the php5.ini file; then,
    • when that didn't work, removed max_execution_time 0 from php5.ini, then
    • added php_value max_execution_time 0 to the .htaccess file in my site's root folder, but that rendered the site inaccessible from the web, until I reverted the .htaccess file back to its original state.

    Do you have any idea how to check that Apache isn't set to timeout at 120 seconds, on GoDaddy? Do you have any other ideas?

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Pablo,

    I would double-check with GoDaddy. I believe you can put some settings into the .htaccess file, but this of course this depends if the server is allowed to register them. Your hosting provider will have the best set of docs for how to configure the server. If your running fast-cgi then you may look for a setting on that as well...

    Cheers~

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Duplicator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic