WordPress.org

Support

Support » Installation » 500 Internal Server Error from Permalink change

500 Internal Server Error from Permalink change

  • I installed wordpress using fantastico and everything worked fine until I tried to change the permalink setting. I wanted to have a file name that consists of the category name followed by topic name. I must have misinterpreted the syntax and whatever I typed in has caused me to get a 500 Internal Server error when I try to get into the admin or the blog.

    The entry in my server error log (in cPanel) is [Fri Mar 18 17:49:37 2005] [alert] [client 67.174.193.147] /home/virtua38/public_html/blog/.htaccess: RewriteRule: bad flag delimiters

    I cannot figure out from the comments in this forum which file I need to edit to fix the problem. It sounds like it might be something wrong in the htaccess file, but I have no idea what to change in it . Any ideas anyone? Any help is much appreciated.
    thanks
    Barry

    [Moderated: .htaccess contents removed – please paste to a text file and post on your site and link to it.]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Have WordPress regenerate the permalink code for you and then copy/paste it into a fresh .htacess file. Maybe you have leftovers from the previous version that are causing you grief.

    Thanks for your reply. How can I get wordpress to regenerate the permalink code? When I try to access the top level blog directory, or the blog/wp-admin directory, I get the server error message.
    Thanks
    Barry

    Barry,
    Can you login to your admin panel? In your browser, navigate to http://yoursite.com/wp-login.php and that should take you to your admin panel. Once there you can go to your OPTIONS menu and select PERMALINKS and regenerate them there.

    what if I can’t login to my admin panel?? I also deleted the values in ‘permalink_structure’ in the wp_options table of the db, but the 500 error is always there…

    Moderator James Huff

    @macmanx

    Delete the .htaccess file.

    this is the worst of all: i don’t have any .htaccess file !!

    Moderator James Huff

    @macmanx

    .htaccess is a hidden (invisible) file. Is your FTP app set to show hidden files?

    i think so. i’ve tried with 2 apps. not only the .htaccess is not there, i can’t create it with none of the apps

    Moderator James Huff

    @macmanx

    This tutorial will teach you how to show hidden files in most popular Windows FTP clients. Please double-check yourself against it: http://www.tamba2.org.uk/wordpress/ftp/

    Ok, thanks macmanx, this tutorial is great!

    now i’m trying with leechFTP, but my server is don’t give me the permissions to do that:

    > DELE .htaccess
    < 550 .htaccess: Forbidden filename

    ah!! but I can RENAME the dir!!! oh yeah!!

    thankiou macmanx!!

    Moderator James Huff

    @macmanx

    It looks like your server doesn’t want you to use .htaccess. If I were you, I’d ask them to give you permanent full access. If they don’t, there are plenty of great hosts out there who do, and moving WordPress is very easy. http://www.tamba2.org.uk/wordpress/move/

    Help!! How do I change the permalinks back to what they used to be? I ran the update to this structure /%postname% but i got the 500 error.

    the links, however, WERE renamed. when I delete the .htaccess file nothing changes. I can log into the control panel, but I can’t open any of the pages or comments, and when I try to clear the structure box in options-permalink.php i get the same 500 error!!

    have erased everything and reinstalled a clean wordpress

    still get the 500 internal server error!!!

    now the best part… at one point after everything went haywire i tried re-writing the links to /index.php/%postname% and that works!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘500 Internal Server Error from Permalink change’ is closed to new replies.
Skip to toolbar