[closed] 500 internal server error after upgrade to 3.5.1 (19 posts)

  1. iceq
    Posted 2 years ago #

    Hi. I upgraded, and since then I get 500 internal server error everytime I log into dashboard, although the website loads fine (front page).
    I renamed plugins folder, and then when going to dashboard I get an error that I need to "reinstall w3-total-cache or remove advanced-cache.php from wp-content.
    If I do that, or if I just put w3-total-cache plugin folder inside "Plugins" directory, I still get the 500 error.

    What's wrong ?

  2. With FTP, delete all the W3TC rewrite rules from the .htaccess file. And rmove advanced-cache.php from wp-content

  3. iceq
    Posted 2 years ago #

    Thank you. I did what you advised, but the problem isn't gone.
    Currently, there's no "advanced-cache.php" in my wp-content, and my .htaccess file contains this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
  4. Reupload all core WP files and folders. Who is the webhost?

  5. iceq
    Posted 2 years ago #

    Thank you. I did that, I deleted all files except wp-content, and re-uploaded new ones from fresh WP package (latest version).

    host is Hostmonster (sister to Bluehost)

    I spoke with them couple of times and they didn't know what's going on.

  6. iceq
    Posted 2 years ago #

    Sadly I am still having the issue, and not it has expanded to another blog of mine :(

    I deleted all files (except WP-content and wp-config) and replaced them with new fresh ones, but to no avail.

  7. iceq
    Posted 2 years ago #

    I am still having the issue and it's blowing up my mind !

  8. kidxrude
    Posted 2 years ago #

    Same here! Different host. I can't even acces my admin pages. Home page loads fine, though not all pages are available. I guess that's cache which are generated by an installed cache plugin.

    Problem is consistent for a few days now.

  9. iceq
    Posted 2 years ago #

    Hi kidxrude. For me, the problem actually turned out to be caused by W3-Total Cache.
    What I did was COMPLETELY DELETE every W3TC file I could find.. it has files spread everywhere, in the plugins folder, in wp-content, and even single files, not only folders. You'll easily recognize them.

    Delete all, and you'll be fine.

  10. Frederick Townes
    Posted 2 years ago #

    I'd really like to work with anyone that had this issue so that I can make sure that this doesn't happen for anyone else. I'll do a free full server optimization for any volunteers.

  11. iceq
    Posted 2 years ago #

    Frederick, that's generous.
    For me, what happened is exactly what I described above.
    It waasn't enough to disable W3TC or even rename the whole plugins folder. My issue was solved only after I deleted EVERY file of the plugin. You must make sure no files can cause such a critical error when there's anything wrong with the plugin. It must crash in the worst case, not cause the WordPress to crash.
    I am more than ready to cooperate in anything else.

  12. Frederick Townes
    Posted 2 years ago #

    Can you send me an email so I can take a look at your server?

  13. iceq
    Posted 2 years ago #

    I am now on a new VPS actually.. not the same shared hosting I was on when I had the problem.
    I still have the shared account though, and I can give you its login details if that helps. But my site is not active there anymore (although the WP files are still there, but the domain points to the new location on the VPS).
    You might want to investigate it because my old shared hosting (Hostmonster / Bluehost) is used by many bloggers.
    If you're interested, this is my email, let me know and i'll send my account details


  14. Frederick Townes
    Posted 2 years ago #

    I'm not trying to solicit people's personal information. I'm trying to have people reach out to me directly so I can investigate their use cases directly. Even if I have accounts on lots of major hosts, that still doesn't account for theme / plugin configuration permutations.

    @iceq, please submit a bug submission form from the support tab of the plugin and I'll be able to see your settings.

  15. Andrew
    Forum moderator
    Posted 2 years ago #

    Can you keep support on these forums so that everyone else who is also experiencing the same issue does not have to email you to find the answer?

  16. Frederick Townes
    Posted 2 years ago #

    No, there are too many issues and they're very rarely the same. Whenever an issue is known I specify that it's included in an upcoming release on the forums.

    I have way to no couple patches to topics in the forums. Furthermore, there is no way for me to see people's settings in the forums, so this is the best that I can do. I realize that it is not ideal for anyone. Sorry.

  17. Ninjini
    Posted 1 year ago #

    I've got this problem now after an upgrade. I'm getting a 500 error after logging in. I've tried deleting all the W3TC files but still have the problem. Maybe I'm missing some files that need to be deleted?

  18. Pioneer Web Design
    Posted 1 year ago #


    Please create a new post for you issue per forum rules.

  19. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Closing this thread as it's about WP3.5.1 which is not relevant to the current version/update. Start a new thread as suggested above.

Topic Closed

This topic has been closed to new replies.

About this Topic