Support » Plugin: BulletProof Security » 500 Internal Server Error after latest update

Viewing 15 replies - 1 through 15 (of 33 total)
  • Plugin Author AITpro

    (@aitpro)

    I see from your other thread that you posted that you stated you deleted or renamed an .htaccess file. Since you have Wordfence installed then there is a possibility that Wordfence needs to see some htaccess code and may actually be causing the 500 error. Not really sure what the cause is yet on your particular website/server, but this information is good to have posted to start troubleshooting with.

    Do these steps and let me know the results and I will continue troubleshooting after you have done these steps:
    1. Use FTP and rename the /wordfence plugin folder and rename the /bulletproof-security plugin folder.
    2. Delete your root and wp-admin htaccess files.

    I have deleted BulletProof folder, I have deleted htaccess, and I have reinstalled WordPress to the latest version manually. But I still have this error. Should I upload Bulletproof manually? What do you mean delete my root file?

    Plugin Author AITpro

    (@aitpro)

    Ok you also need to eliminate Wordfence too since Wordfence could either be the cause of the problem or it could be a combination problem or something else that I have not figured out yet. Rename the /wordfence plugin folder.

    You should see a root htaccess file in your website root folder (the folder where WordPress is installed). If you do not see the root htaccess file then make sure you have set your FTP application to “show hidden files”.

    Ok…

    I realized what you meant by the root file, the .htaccess file in the root folder. I actually just manually reinstalled the latest wordpress, deleted BulletProof, reset my DB password, etc. and it looks like I have my site back. But I’m a little skeptical of reinstalling Bulletproof because it’ll edit the htaccess files. But let me try it anyways since I updated WP. I’ll let you know how it goes.

    Plugin Author AITpro

    (@aitpro)

    Are you using Wordfence Falcon? If so, a 500 error is a very common problem with Falcon. If you google Wordfence 500 error you will see lots of search results that are all caused by Wordfence Falcon. I do not know exactly how Wordfence Falcon works, but I know it uses htaccess code. So Falcon may have dependent htaccess code that it needs to find in the root htaccess file and that could be the cause of the 500 error. Just making logical guesses since a 500 does not usually occur with BPS upgrades.

    Ok. It’s the bulletproof. I updated to latest WordPress, reset everything including permalinks, which fixed the links.

    I reinstalled BulletProof and AS SOON AS I CLICK SETUP WIZARD, and it shows me the results page, when I click the homepage link, I get the internal server error message.

    Plugin Author AITpro

    (@aitpro)

    We were posting at the same time. Great that you got your site back up, but I would like to continue troubleshooting with you to find the root cause of the problem so that it does not happen again in the future. 😉

    Sure, what info do you need? I am reinstalling WP for the 2nd time because I reinstalled BulletProof again to check which plugin the cause was. Yes, it turns out it’s the setup wizard for BulletProof. And I am using the latest WP version, which I just downloaded 5 min ago.

    Plugin Author AITpro

    (@aitpro)

    Posting at the same time again. 😉

    Ok lets analyze and find out exactly what is going on.
    Download this file to your computer: /bulletproof-security/admin/htaccess/secure.htaccess
    Upload it to your WordPress installation folder and rename it to .htaccess.
    Let me know if you see a 500 error at this point.

    Plugin Author AITpro

    (@aitpro)

    Yep, I understand that something that is occurring during running the Setup Wizard is causing the problem, but the reasons for that could be about 5 or so different things. So we will do a process of elimination to find out exactly what is causing the problem on your particular website/server.

    Yes. I did as you asked and renamed it. I get the 500 Internal Server Error.

    Plugin Author AITpro

    (@aitpro)

    Ok delete the .htaccess file that you uploaded to your website. You do not need to reinstall WordPress again.

    1. Ok next manually edit the secure.htaccess file that you downloaded to your computer and comment out these lines of code with # signs as shown below. #Options -Indexes and #DirectoryIndex index.php index.html /index.php lines of code have been commented out with # signs.
    2. Upload the secure.htaccess file to your WordPress installation folder and rename it to .htaccess.
    3. Let me know if you see a 500 error at this point.

    # DO NOT SHOW DIRECTORY LISTING
    # Disallow mod_autoindex from displaying a directory listing
    # If a 500 Internal Server Error occurs when activating Root BulletProof Mode
    # copy the entire DO NOT SHOW DIRECTORY LISTING and DIRECTORY INDEX sections of code
    # and paste it into BPS Custom Code and comment out Options -Indexes
    # by adding a # sign in front of it.
    # Example: #Options -Indexes
    #Options -Indexes
    
    # DIRECTORY INDEX FORCE INDEX.PHP
    # Use index.php as default directory index file. index.html will be ignored.
    # If a 500 Internal Server Error occurs when activating Root BulletProof Mode
    # copy the entire DO NOT SHOW DIRECTORY LISTING and DIRECTORY INDEX sections of code
    # and paste it into BPS Custom Code and comment out DirectoryIndex
    # by adding a # sign in front of it.
    # Example: #DirectoryIndex index.php index.html /index.php
    #DirectoryIndex index.php index.html /index.php

    I commented them out and re-uploaded. I still get the 500 Error.

    Plugin Author AITpro

    (@aitpro)

    Is the Wordfence plugin folder renamed? If not, rename the wordfence plugin folder to /_wordfence.
    Let me know if you still see a 500 error at this point.

    Plugin Author AITpro

    (@aitpro)

    [deleted duplicate post]

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘500 Internal Server Error after latest update’ is closed to new replies.