500 Internal Server Error After Adding Subdomain (4 posts)

  1. salem80
    Posted 4 years ago #

    I have Problem in titillate subdomain to wordpress
    I Add this Line to my wp-config.php

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'alkoonsoft.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    And edit .htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    After finish adding subdomain (mobile.alkoonsoft.com) in wordpress and Cpanel . I got error message when trying access mobile.alkoonsoft.com/wp-admin

    Clearly it's .htaccess file fault I try to delete whole .htaccess contents and keep WordPress code with no hob .

  2. 500 errors means your .htaccess isn't being read correctly.

    Do you have mod_rewrite on, and do you have allowoverride set to ALL in your httpd.conf?

  3. salem80
    Posted 4 years ago #

    Hi Ipstenu thanks for replay
    Currently I have no access to httpd.conf File because of hosting limits
    And I'm not setting mod_rewrite on now but I will .
    about allowoverride set to ALL I read in Cpanel doc that I can use httpd.conf script on .htaccess but I don't know how exactly that work with allowoverride ALL

  4. And I'm not setting mod_rewrite on now but I will .

    Yeah, do that first, see if it works. It's required for Multisite.

Topic Closed

This topic has been closed to new replies.

About this Topic