WordPress.org

Support

Support » Plugins and Hacks » iThemes Security (formerly Better WP Security) » 500 internal server error after activating Better WP Security

500 internal server error after activating Better WP Security

Viewing 4 replies - 1 through 4 (of 4 total)
  • I also cannot view any of the pages on my site except for the home page.

    Try logging in via FTP or File Manager to start.
    Go to wp-contents/plugins
    Rename wp security plugin temporarily by adding .something to end of directory name.

    Thank you Hack Repair Guy. I deleted the Better WordPress Security folder, so I am unable to edit its name.

    Robynt – I don’t know if you’re still dealing with this issue or not, but try renaming your .htaccess file to see if that makes a difference. I just found that something in our installation (I don’t know whether it was Better WP Security or another plugin, yet) edited our .htaccess file and must have missed the mark on where to edit things, so we ended up with some duplicated information within the file; and ended up with some closing </files> tags that didn’t have opening <files> tags, which caused our site to start throwing 500 errors. Removing that extraneous code from .htaccess fixed the issue.

    If that is the issue, and you’re running a multisite installation, you’ll have to dig through .htaccess and actually fix it, but if you’re using a regular WordPress install, you should be able to just delete .htaccess and then visit Settings -> Permalinks to have WordPress automatically generate a new copy of the file.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘500 internal server error after activating Better WP Security’ is closed to new replies.
Skip to toolbar