WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
500 internal server error after activating Better WP Security (5 posts)

  1. robynt
    Member
    Posted 2 years ago #

    It seems that logging in after activating this plug-in is a common problem. I have tried doing a few things to remedy this situation myself, but nothing is working. Please help!

    Here is what I did:

    I changed the plug-in setting to "hide" the backend log-in, so instead of logging in at /wp-admin, I changed mine to /make-changes.

    Then the error- I cannot log in.

    So this is what I did to try and fix it, and nothing has worked so hopefully I didn't make the situation worse:
    -created a new, blank .htaccess file
    -went line by line through the wp_options column in phpmyadmin and reset my plugins. Starting with active_plugins (changing that to a:0:{} ) and all of the ones that had names associated with BWPS
    -I also dropped all of the tables that had to do with BWPS
    -I used FTP to delete the plug-in files

    I think that that is all that I tried. If anyone can offer advice, I would really appreciate it. I am supposed to have my company's site up and running this week and this mistake couldn't have come at a worse time.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. robynt
    Member
    Posted 2 years ago #

    I also cannot view any of the pages on my site except for the home page.

  3. The Hack Repair Guy
    Member
    Posted 2 years ago #

    Try logging in via FTP or File Manager to start.
    Go to wp-contents/plugins
    Rename wp security plugin temporarily by adding .something to end of directory name.

  4. robynt
    Member
    Posted 2 years ago #

    Thank you Hack Repair Guy. I deleted the Better WordPress Security folder, so I am unable to edit its name.

  5. Curtiss Grymala
    Member
    Posted 2 years ago #

    Robynt - I don't know if you're still dealing with this issue or not, but try renaming your .htaccess file to see if that makes a difference. I just found that something in our installation (I don't know whether it was Better WP Security or another plugin, yet) edited our .htaccess file and must have missed the mark on where to edit things, so we ended up with some duplicated information within the file; and ended up with some closing </files> tags that didn't have opening <files> tags, which caused our site to start throwing 500 errors. Removing that extraneous code from .htaccess fixed the issue.

    If that is the issue, and you're running a multisite installation, you'll have to dig through .htaccess and actually fix it, but if you're using a regular WordPress install, you should be able to just delete .htaccess and then visit Settings -> Permalinks to have WordPress automatically generate a new copy of the file.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic