Support » Fixing WordPress » 500: Internal server error

  • Resolved camolez


    Hi everyone, I am struggling, trying to import an XML file into my wordpress. I’ve tried several templates with their respective XML and I always get the same error, the page takes a long time to load, it doesn’t load, then I get this:

    ///////////////////////////////////////// 500: Internal server error

    This error is generated when a script running on the server could not be implemented or permissions are incorrectly assigned for files or directories

    Troubleshooting suggestions:

    Temporarily disable any rewrite rules by renaming your .htaccess file if it exists.

    Ensure that any CGI or Perl scripts have at least .755. permissions.

    If trying to run PHP and you get this error, you may have an invalid php.ini in your /cgi-bin, or may be missing your php.dat file in this folder.


    I would appreciate if some expert could help me !!!


Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator t-p


    Error 500 ISE is very generic and can be caused by numerous underlying issues. Here are some thing you can try to solve it: – Your first step should be checking your site’s error logs for a more specific error message. If you need help locating them, ask your hosting provider to help you with that.
    – check with your host if the domain name is configured properly to point to public_html folder
    – It may indicate .htaccess issue. Regenerate .htaccess, and be sure the encoding in your text editor is Unicode No BOM
    – It may also indicate a problem with the configuration on the server. Usually your hosting company tech support can help.
    – it could be problem with the plugins, try resetting the plugins folder by FTP or phpMyAdmin.
    – it could be a problem with the theme. Momentarily, try switching to the default WordPress theme via FTP or whatever file management application your host provides by renaming your current theme to rule out any theme specific issue.
    – If the above troubleshooting steps fail to resolve the issue, try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!

    MANY MANY MANY thank Tara !! At least for answering my post.

    This error has become a frustrating nightmare lately. It’s all about an .XML file that doesn’t upload as explained by the theme author. Problem is, it’s not the first time nor with the same theme… it happened before and I just can’t figure how to solve on my own, in an easy newbie sort of way. I have contacted my host provider (Network Solutions / US) and they blame WP… furthermore, if I need special attention to this problem… well, I must register to a private assistance (around USD50/month), which I refuse to pay for some service that should need/use only once.

    I have already tried to install WP from scratch at least 8 times, I’ve tried different themes and the problem is always the same… uploading this XML file (in order to get the DEMO theme up and running)… I got the picture, that definitely the problem lays in the server.

    After hours of reading the WP support, I managed to find out how to change chmods and permissions through http://FTP... which I did… changing all permissions to 777 (risky but) just to see if it would work… so far, nothing happened, problem remains.

    Any other idea, perhaps?

    Thansk again

    Moderator t-p


    Hi everyone, I am struggling, trying to import an XML file into my wordpress.

    – Where are you trying to import from?
    -Are you trying to importinto particular table of the DB?
    -Are you trying to replace/restore the entire DB with this file?
    – Is this XML file from the same version of the WP (3.7.1.)?

    this may be related:

    After purchasing a theme from, I have downloaded and intalled the theme, uploading the right .zip file. Once the full instalation was accomplished and working fine, I had to upload the xml file provided in the author package, in order to load the DEMO theme…

    My knowledge is very limited when it comes to WP and codes, so I just followed the tutorial taht says:

    Now you have this theme installed and activated, next is open the folder “Assets” inside of the theme package, you will see a file of “folioway.demo.content.xml”, this is the file that holds all contents of the demo site, log into your site back-end and then “Tools > Import > WordPress”, on a newly created site, you will be asked to install the “WordPress Importer” plugin, install the plugin and then use it to import the file in question, choose “Download and import file attachments” then submit, it is a huge file, waiting for the importer to finish its work.

    Then, this is where the problem begin… I get the 500 error message….

    I wouldn’t know how to import anything in any particular table.

    How can I check if this xml file is compatible with the latest WP?

    After writing to the author, ENVATO answer was:

    If you were doing it right that uploading the demo file via WordPress Admin > Tools > Import, then there is problem with your WordPress installation, at least the import script doesn’t work. All i can see is it might be a file permission issue from the error message. Your hosting support or is where you should post the question to.


    Then here I am !

    Moderator t-p


    After purchasing a theme from,

    My suggestion is to contact thetheme’s developers: Themeforest:

    Thanks Tara !!! As you’ve seen, the author (developer of the theme) sent me here or towards the host provider… the host send me back to the author… ouch…




    When you pay for a theme, you pay for support too. And make sure in future that whatever theme, plugin or software that you purchase is only from a vendor that’s committed to providing support too. Additionally, the volunteers here (no one is paid) helping you out, including myself, do not have access to any themes that’s downloaded/purchased from commercial sources.


    Also review:

    Krishna, THANK YOU for your advice !!! Please, don’t misunderstand me, I’m very grateful for any help I can get… and it’s GREAT there are people like you… really!!! Being a rookie in the code world is a nightmare. As you can see above, I did contact the developer who just told me, and I quote:

    ” If you were doing it right that uploading the demo file via WordPress Admin > Tools > Import, then there is problem with your WordPress installation, at least the import script doesn’t work. All i can see is it might be a file permission issue from the error message. Your hosting support or is where you should post the question to.”


    Tara & Krishna, thanks again !!!!




    Though, unfortunately, we cannot help much in such situations, we are not against commercial themes. WordPress has a section listing commercial themes.

    And I myself use a commercial theme for two of my sites, including the one linked to my name (on the left), and I use themes from WordPress repository for my other sites. But I never had any problem with that commercial theme vendor (studio press).

    We hope you get the issue resolved soon. Thanks for your understanding! 🙂

    Big THX for the tips Krishna! Shame on me, I didn’t know about the commercial themes. I saw some free WP templates that show while installing the wp itself, but I didn’t really like it… too bloggish… I will have a closer look into the commercial ones… thx 🙂

    PS: If you know any interesting template more related to graphic design or photographer portfolio, I’ll appreciate the suggestion.




    Thank you Krishna! Concerning the previous subject, about the error… there are some updates.

    After recontacting the theme author and giving him my login access, he uploaded the xml without any problem.

    I then started to think the problem could be in my computer.

    I’m using a Mac mini, Maverick iOs (the latest), using Chrome as a browser…
    It seems weird to me that the problem doens’t happened to him as well.

    I have then deleted the wordpress importer plugin and re-installed… now, it got worst from my side… the plugin doesn’t even load… everytime I try to access the plugin, I get this message:

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 30720 bytes) in /data/19/2/49/117/2864606/user/3151447/htdocs/bcwp/wp-admin/includes/menu.php on line 174

    I looks chinese to my eyes…

    This “fatal error” is happening on both Chrome and SAFARI (native Apple browser)

    Any idea what this could be?

    I’ve tried uploading the xml file via FTP (Filezilla) and it loads beautifully… so it appears that the problem is not coming from server side… now I’m wondering if the problem is coming from WP, my Mac or some miscommunication between them?

    Moderator t-p


    try increasing memory available for php.

    There are also, numereous threads that deal with this topic. For example:

    Thank you Tara, this is like stepping in a wild jungle by night to me, no compass, no food, no torch, no knife… I will have a look on the link you just sent… hoping I’ll understand something.

    thx again

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘500: Internal server error’ is closed to new replies.