500 Internal Server Error (8 posts)

  1. vrikis
    Posted 7 years ago #

    Hey everyone!

    I used to have wordpress installed on my hosting (www.one.com) and used it for a while and everything worked well. Once I stopped using it and forgot my password and stuff I just decided to start with a fresh wordpress install. I FTP'd into my hosting server and deleted everything and uploaded a fresh copy of wordpress with the wp-config.php file edited and ready. I got the following error message:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@one.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    I'm not sure why that happened, but as the error advised, I emailed them this:

    Hi, I was just trying to install WordPress on my website (I used to have it on, then wiped the root folder but I presume the database still had some keys in which are conflicting). This is the error I get: <<Read error above>>

    Hopefully you can help with this.

    Thanks, Kyle Saric | http://www.kylesaric.com

    The following day I got a respone:

    Dear Kyle,

    The internal server error is usually because of some error in the .htaccess file. Please try renaming the .htaccess file in both the root directory and wordpress directory to htaccess.txt.

    You can delete the wordpress tables from earlier installations using phpmyadmin. Followig URL contains the link for the login page :


    - Login to Phpmyadmin
    - Click on 'database_name' at the top_left_corner.
    - This will display all tables on the right pane.
    - Here select all tables with the prefix wp_
    - Scroll down the page and select 'Drop' from the drop down. This will delete all tables.

    Best Regards


    I have deleted the tables and everything from my database, but I have no idea where this .htaccess file is. I can't seem to find it. I still get the same error message.

    Any help would be hugely appreciated!


  2. Samuel B
    Posted 7 years ago #

    you may have to turn on "show hidden files" in your ftp client to see the .htaccess
    although you should be able to see it from host's file manager

  3. vrikis
    Posted 7 years ago #

    I can't find out how to do that. Does anyone know how to do that in Transmit (Mac software)?

  4. vrikis
    Posted 7 years ago #

    anyone know of any other reasons as to why...?

  5. mattbettiol
    Posted 6 years ago #

    I am going to post this everywhere that someone write about this so that you can try this solution out.

    Make that if you have reinstalled wordpress, that you .htaccess file is correct. If you have wordpress installed on your main directory(you see wordpress content when you first enter the site) your .htaccess file should look similar to this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
  6. diegopen
    Posted 6 years ago #

    I've tried to upgrade from 2.8 to 2.8.3 with no success. 500 Internal Server Error to me too. I already quit using WP in other 2 blogs because of this upgrading issues..
    My .https looks just like mattbettiol posted. Now I'm trying to restore all folders from a bkup. If this is not working I will try also restoring the db too.. Any further tip if this two things wouldn't work? (apart from moving this site to other cms). Thanks in advanced.


  7. p0yo77
    Posted 6 years ago #

    Today I got this error, and after trying one or another thing I found this post.
    Then I tried to rename the .htaccess file to .htacces.txt as the post says up there, tried to enter my site and finally it worked, but then you can't go anywhere but the home, thats where my backup came and saved my tiny chair-warmer. I've uploaded an older .htaccess file (from a backup i've made yesterday(thank good for my paranoia)). and the only thing left to do is to change the permissions to 666 (I guess this is the trick, when you change the permissions to 666 the devil access your server and make your site work xD). well that's pretty much all you have to do.

    the other reason of getting this error is when your php server is running out of memory if that happens the only thing to do is create a text file named php.ini and put the next line inside
    that will alocate an extra 20 mb to your php compiller and the site should work just fine, any doubts my email is poyo77@gmail.com

  8. cruth
    Posted 6 years ago #

    Just want to add that I had this 500 error, and I solved it deactivating all of my plugins, then deleted some I wasn't sure of and really needing. This solved the problem, for me.

Topic Closed

This topic has been closed to new replies.

About this Topic