WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 500 Internal Server Error

[Resolved] 500 Internal Server Error

  • After attempting to upgrade to the newest version of WP on this site: http://modelingbyanatomy.net

    I received the error notification: “Briefly unavailable for scheduled maintenance. Check back in a minute.”
    After searching the forum for a solution, I found the fantastic advice of: “delete the .maintenance file”.

    Now that I’ve done that, I receive a notice stating: “HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.”

    Fantastic! Any advice now? While deleting and re-uploading everything is possible, there are multiple blog entries that cannot be saved. The idea of losing those is pretty unacceptable so any advice that doesn’t involve deleting everything and starting over again is more than welcome.

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    Okay, did both of those things – Nothing. It still throws up the same error.

    esmi

    @esmi

    Forum Moderator

    Try:

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade manually using wp-admin/upgrade.php.

    try accessing /wp-admin/edit-comments.php and you’ll get to the admin interface

    Re-uploading everything worked somewhat. I am able to access the back end of the site. However there is now a new problem: None of the pages work. All I can get when I click a link is a 404 Error.

    The pages and their content all appear on the back end but they don’t work as links. This isn’t a custom menu and I’ve tried deleting and re-adding them and that doesn’t work either.

    Thoughts?

    Never mind. I changed my perma-link structure to month and name and now pages appear.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] 500 Internal Server Error’ is closed to new replies.
Skip to toolbar