Support » Fixing WordPress » 500 Internal Error Fix

  • I had a problem which I fixed and am posting it here just incase anyone else has the same problem.

    My situation: I was developing a site on my server with a directory path of “/sitename/”. I successfully transferred it over to a new server with the directory path of “/” but I got the 500 internal error on every page EXCEPT the homepage.

    The .htaccess file read:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /sitename/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /sitename/index.php [L]
    # END WordPress

    The fix:
    RewriteBase /
    RewriteRule . /index.php [L]

    (just took out the “sitename” so it pointed to the root directory). Simple problem and simple fix, just thought it may help if you forget like I did.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I think this post is helpful. Just in case anymore needs to see the default .htaccess for wordpress should be.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    So i have a question.. my WordPress site is ALL jacked up. I’m getting the 500 error everywhere I go. Here is my htacess… thoughts?

    [Very large .htaccess file moderated as per the Forum Rules. Please use the pastebin]

    From the looks of it, it seems like you are possibly using the W3 Total Cache plugin [ ]

    I would suggest starting with the default WordPress .htaccess file and see if it works. If it does then you can try installing the W3 Total cache plugin. Then once you remove the plugin and start with default .htaccess file you can try to reconfigure the plugin and move forward:

    Install W3 Total Cache and try the following settings
    * Page Cache: Enable
    * Page Cache Method: Disk (Enhanced)
    * Database Cache: Enable

    Have have heard that some people are having an issue with W3 Total cache not working for them. If this does not work for you then start with the default .htaccess file for WordPress and try using WP Super cache:

    Thank you for your help!
    Though i’m very new to all this. Is there a solution of installing the “W3 total cache” plugin? What should i do to .htaccess (and where is it)?

    Sorry i’m a bit slow :S

    I can’t even get to my admin side now to deactivate the W3 total cache.. so will it break my site if i just FTP into the plugins folder and delete everything the plugin from there?

    If you are logged into your account through FTP you can try to rename the actual W3 Total cache plugin folder. Also you can rename “plugins” to something like “plugins-fixing” to temporarily disable all of your plugins so you can make the right changes. Once done remember to change the folders back to their original names



    Forum Moderator

    I would also recommend that you check the W3 Total Cache documentation for any specific un-install steps.

    So i use the “W3 total cache” to import my .xml-file that i made? That is i select it at “Import configuration:” at the bottom of the page?

    Or am i totally lost here :P?

    Dear W3 Total Cache

    You ruined my life for the past few weeks. So what did I do? I deleted you entirely from my life.


    Okay My site is running amazing now that W3 is gone. It’s interesting because I thought that would only help.. I even setup a CDN too.

    Now I have a cu3er error on several pages..
    Fatal error: Call to undefined function display_CU3ER() in /home/content/e/m/m/emmwadmin/html/wp-content/themes/wpress/page.php on line 13


    Do I dare try to reinstall this?

    i get the error 500 Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    what should i do

    This solution sometimes works for me:

    1. Change permalink settings to default
    2. View page*
    3. Revert permalink setting to however it was before

    *Optional step, but I do it to make sure I haven’t accidentally made a programming error, such as an infinite loop

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘500 Internal Error Fix’ is closed to new replies.