Support » Fixing WordPress » 500 Internal error

  • Hi All,

    I’m hoping this is the correct place to request help, i’m at a loss with this.

    I work for an IT company and a client asked us to process an upgrade manually to the latest version of WordPress, due to the automatic update feature failing to unpack the zip file. I have processed these types of upgrades for my personal website before and never had any issues but I’ve run into a wall with this one.

    What I done…

    I replaced the WP-INCLUDES and WP-ADMIN and also copied the files inside the WP-CONTENT folder (did not delete etc)
    The database (myphpadmin hosted on UK2) was then requested to be upgraded, once I clicked the DB upgrade link the page crashed / wouldn’t load and nothing would proceed.

    I tried reverting the WP-INCLUDES / WP-ADMIN etc folders back to the original version but this has caused a 500 internal error and I’m unable to view the website or login to wp-admin.

    I have tried the usual:

    1) creating php.ini files and setting memory to 128mb – no luck
    2) created a new .htacess file with the same entries – no luck
    3) disabled the plugins through cpanel – no luck
    4) disabled the ionic one theme to try and get wordpress to revert to the default website – no luck
    5) Transferring the latest WP-ADMIN / WP-INCLUDES

    At the moment the website is showing The theme directory “iconic-one” does not exist. – This is due to it being disabled by adding iconic-one.dis.

    If anyone has any ideas, I would be very grateful – look forward to any replies. 🙂

    kind regards,

    martin.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi @martinsly , make sure all the core files are installed. Currently you’re getting blank screen of death. You can re-install core files manually via FTP or cPanel.

    Hi Magefix,

    thank you for the reply.

    I have logged into UK2 Cpanel and just uploaded the latest core files again but i’m still getting the same issue.

    I zip the folders and then uploaded and extract directly through the Cpanel – the files are replaced but still no luck.

    any other ideas? :/

    forgot to say – i’ve enabled the theme again ionic one and I just get http 500 error

    I also tried changing the theme within wp-options to the default WordPress theme but this made no difference.

    I would let you have our Cpanel login but we have other clients hosted in there.

    cheers,

    martin.

    @martinsly try to rename plugins and theme folder – see if 500 error goes away. if error is still on, try to rename .htaccess to htaccess.dis.

    If i rename the themes and plugin folder to .dis at the end I get the below

    “The theme directory “iconic-one” does not exist.
    ERROR: the themes directory is either empty or doesn’t exist. Please check your installation.”

    renamed the themes and plugin folder back to normal and renamed the .htaccess to .dis and still the same error and also tried with .dis on the plugin and theme folder.

    At least he main site shows the themes folders are missing, wp-admin wont even load due to http 500 error.

    Code inside .htaccess:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    cheers,

    If you rename themes folder and you get the missing theme error, then it means there’s something theme-related which triggers the errors. Also that means you should be able to login to dashboard.

    Try to manually re-install theme files: https://wordpress.org/themes/iconic-one/

    Are you able to enable debug mode, to learn more about the error?
    If possible, enable debug via wp-config.php and post the error details here:
    https://wordpress.org/support/article/debugging-in-wordpress/

    hmm ok thank you, even when I can see the theme error i’m unable to login to the dashboard – just comes up 500 internal error.

    Just downloaded the theme files again and imported but I just get a white screen now with no error about a missing theme – still unable to login to wp-admin

    https://candmmodels.co.uk/wp-admin/
    This page isn’t workingcandmmodels.co.uk is currently unable to handle this request.
    HTTP ERROR 500

    I will give the debug option a go now and post the results.

    thank you.

    Notice: date.php is deprecated since version 5.3.0! Use wp-includes/class-wp-date-query.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802

    Notice: class-oembed.php is deprecated since version 5.3.0! Use wp-includes/class-wp-oembed.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802

    Fatal error: Uncaught Error: Class ‘WP_Block_Type_Registry’ not found in /home/candmmod/public_html/wp-includes/script-loader.php:2872 Stack trace: #0 /home/candmmod/public_html/wp-includes/class-wp-hook.php(288): wp_enqueue_registered_block_scripts_and_styles(”) #1 /home/candmmod/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(”, Array) #2 /home/candmmod/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #3 /home/candmmod/public_html/wp-includes/script-loader.php(2856): do_action(‘enqueue_block_a…’) #4 /home/candmmod/public_html/wp-includes/class-wp-hook.php(288): wp_common_block_scripts_and_styles(”) #5 /home/candmmod/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(”, Array) #6 /home/candmmod/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #7 /home/candmmod/public_html/wp-includes/script-loader.php(2670): do_action(‘wp_enqueue_scri…’) #8 /home/candmmod/public_html/wp-includes/class-wp-hook.php(288): wp_enqueue_scripts(”) #9 /home/c in /home/candmmod/public_html/wp-includes/script-loader.php on line 2872

    Also when I try to access the admin portal I get the below

    Notice: date.php is deprecated since version 5.3.0! Use wp-includes/class-wp-date-query.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802

    Notice: class-oembed.php is deprecated since version 5.3.0! Use wp-includes/class-wp-oembed.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802

    Warning: Cannot modify header information – headers already sent by (output started at /home/candmmod/public_html/wp-includes/functions.php:4802) in /home/candmmod/public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home/candmmod/public_html/wp-includes/functions.php:4802) in /home/candmmod/public_html/wp-includes/pluggable.php on line 1268

    There you go, it’s still a progress, you’re getting something. If you disable both plugins and themes folders, you get the same errors?

    Also can you check the current PHP version? It should be 7.3 or latest.
    Safe PHP versions: https://wordpress.org/about/requirements/

    An error 500 is a web server error, it wouldn’t typically be caused by something on your end and the fact you’ve tried multiple PCs and browsers support that.

    I’m guessing it’s either a problem with one or more servers or something in the path between you and wordpress.

    with themes and plugins with .dis at the end when browsing to the main site.

    Notice: date.php is deprecated since version 5.3.0! Use wp-includes/class-wp-date-query.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802

    Notice: class-oembed.php is deprecated since version 5.3.0! Use wp-includes/class-wp-oembed.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802
    The theme directory “iconic-one” does not exist.
    ERROR: the themes directory is either empty or doesn’t exist. Please check your installation.

    When going to wp-admin

    Notice: date.php is deprecated since version 5.3.0! Use wp-includes/class-wp-date-query.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802

    Notice: class-oembed.php is deprecated since version 5.3.0! Use wp-includes/class-wp-oembed.php instead. in /home/candmmod/public_html/wp-includes/functions.php on line 4802

    Warning: Cannot modify header information – headers already sent by (output started at /home/candmmod/public_html/wp-includes/functions.php:4802) in /home/candmmod/public_html/wp-includes/functions.php on line 6029

    Warning: Cannot modify header information – headers already sent by (output started at /home/candmmod/public_html/wp-includes/functions.php:4802) in /home/candmmod/public_html/wp-admin/includes/misc.php on line 1252

    Warning: Cannot modify header information – headers already sent by (output started at /home/candmmod/public_html/wp-includes/functions.php:4802) in /home/candmmod/public_html/wp-admin/admin-header.php on line 9

    Fatal error: Uncaught Error: Call to undefined function wp_recovery_mode() in /home/candmmod/public_html/wp-includes/load.php:811 Stack trace: #0 /home/candmmod/public_html/wp-admin/admin-header.php(55): wp_is_recovery_mode() #1 /home/candmmod/public_html/wp-admin/index.php(111): include(‘/home/candmmod/…’) #2 {main} thrown in /home/candmmod/public_html/wp-includes/load.php on line 811

    Just checked on UK2 and myPHPadmin looks very out of date!

    Version information: 4.9.0.1
    Documentation
    Official Homepage
    Contribute
    Get support
    List of changes
    License

    I will look into getting php updates with uk2 to see if that resolves the issues.
    apologies, I never made this website and the engineer who did previously has now left the business.

    thanks again

    Good news!!!!!

    The website is now back online and working with the theme and woo commerce. 🙂

    I restored from a backup basically…

    Even know i done this 20 or so times…. I copied the previous WP-INCLUDES – WP-CONTENT – CGI-BIN and WP-ADMIN and it started working again – why this didn’t work originally i’m still lost.

    thanks for all your assistance this morning, very much appreciated. 🙂

    have a good day

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.