Support » Plugin: Jetpack by WordPress.com » 500 Error with Jetpack 4.8 Update

  • Resolved siutouamy

    (@siutouamy)


    I’ve been reading about the problems people are having with the latest Jetpack update. Mine is installing correctly, but it makes the site render a 500 Error. Trying to get it reversed now 🙁

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Sorry about that! We’ve made some changes to the Sitemaps feature in Jetpack 4.8, and inadvertently used code that isn’t compatible with old versions of PHP (PHP 5.3 or less). That’s most likely what’s causing the issue on your site.

    We’ll release a new update to solve that problem, but until then I’m afraid I can only recommend the following:

    1. Contact your hosting provider and ask them if it is possible for you to use a more recent version of PHP. PHP 7 is the recommended version of PHP for WordPress, so if they can update you to PHP 7 that would be great.
    2. Remove the Jetpack plugin from your site until we release an update.
    3. Force Deactivate the Sitemaps module by installing this must-use plugin on your site. You can do so by following the instructions in the file.

    Really sorry for all the trouble!

    I’ll post again here once I have some news.

    Update killed the site with the white screen of death. FTP removal and replacement got site back but plugin won’t activate – for reason given above.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @digbymaass Could you try one of the solutions I mentioned above, and let me know if it helps?

    I contacted by server provider and they restored my wordpress to my latest version 🙂 will wait for the update fix then. Thank you, Jeremy.

    I’ve uploaded the old version from backups so no problem but I will ask the ISP to update PHP as there’s at least one other plugin that needs it.

    @jeherve, could you tell us, when you expect to release the new update?

    Actually, PHP update did the work! Thanks 🙂

    The ISP won’t update the PHP (v 5.3.29) which is very annoying. They say the relevant shared server has legacy stuff on it that might break if they updated it. I have no way of judging if this is nonsense or not!
    They would migrate us to a new server with an up to date PHP but Mailman is not enabled on it. Since we rely on Mailman, and marketing email alternatives are not suitable for our running club, this is not an option. They have gone silent when I asked why they couldn’t enable it.
    This is all an aggravation I don’t need!

    Strangely, my site was having the same issue despite being set to PHP 7.0. It was so bad I couldn’t even get /wp-admin access without getting a 500 error. Just on a lark, I went into my hosting settings and rolled it back to PHP 5.6, which fixed the issue. I’ve now deactivated Jetpack and rolled it back to using 7.0. Hopefully you get to the bottom of this soon.

    It took a while to figure out what was going on, but the new Jetpack update today crashed our site as well. We love Jetpack, but have had to remove the plugin to get our site online. Very disappointed!

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Sorry everyone for all the trouble! We’ve just released 4.8.1 to solve the issue mentioned in this thread.

    You can read more about this release here:
    http://wp.me/p1moTy-4N5

    Please update to 4.8.1 as soon as possible to see if that fixes that issue for you. Also, if you’re using WP Rocket, please update that to the latest version as well.

    If you continue to experience issues, could you please try to delete the Jetpack plugin, and reinstall it from scratch? If that doesn’t help either, you can start a new thread here with as much information as possible about the errors you see on your site:
    https://wordpress.org/support/plugin/jetpack#new-post

    Thank you, and again, sorry for the trouble! While we do our best to test things prior to release, sometimes things fall through the cracks. We’ve added additional measures to make sure this type of error doesn’t happen again.

    4.8.1 works for me except now my jetpack is disconnected from my wordpress account;
    When i “connect jetpack” it says it works (“jetpack is now connedted”) but in my dashboard it appears as though jetpack is still not connected.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    When i “connect jetpack” it says it works (“jetpack is now connedted”) but in my dashboard it appears as though jetpack is still not connected.

    @ebeighe Can you please use Jetpack’s Debugger module to send us some more information about your site?

    1. Go to the Jetpack page in your dashboard.
    2. Click on the Debug link appearing at the bottom of the page.
    3. Click the link that says “click here to contact Jetpack support.”
    4. Fill in the description box and your name and email address.
    5. Click the “Contact Support” button to send us the debug results privately. It’s best not to post this information on public forums, as it contains private details about your site.

    Thanks!

    I updated today to 4.8.2 and it tanked my website with the 500 error. PHP version is 5.6.27. GoDaddy had to disable all plugins to restore the site. I reactivated all but JetPack and it is working fine.

    Mike D

    (@mrmikedavis)

    I updated today to 4.8.2 and it tanked my website with the 500 error.

    Same problem here. At least 2 dozen websites I manage are 500 after auto update to Jetpack 4.8.2

    The only solution I have found is clean install of WordPress and restore from Backup DB. That is a nightmare if you’re a developer like me managing multiple websites. Moving forward, I won’t use Jetpack autoupdate plugins feature ever again. Never.

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.