Support » Plugin: WooCommerce CardConnect Payment Gateway » 500 error upgrading to 3.0.0

  • Resolved Timothy Wood

    (@codearachnid)


    Fatal error when upgrading:

    
    PHP Warning:  include_once(vendor/autoload.php): failed to open stream: No such file or directory in /mnt/content/wp-content/plugins/cardconnect-payment-module/cardconnect-payment-gateway.php on line 50
    PHP Warning:  include_once(): Failed opening 'vendor/autoload.php' for inclusion (include_path='.:/usr/share/php:/mnt/content/wp-content/plugins/cx-logo-inside-nav-master/classes/phpQuery/:/mnt/content/wp-content/plugins/cx-logo-inside-nav-master/classes/phpQuery/plugins/:/mnt/content/wp-content/plugins/cardconnect-payment-module/includes') in /mnt/content/wp-content/plugins/cardconnect-payment-module/cardconnect-payment-gateway.php on line 50
    PHP Fatal error:  Uncaught Error: Class 'Raven_Autoloader' not found in /mnt/content/wp-content/plugins/cardconnect-payment-module/cardconnect-payment-gateway.php:55
    
    • This topic was modified 1 year, 3 months ago by Timothy Wood. Reason: fix code formatting
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author RexAK

    (@rexak)

    Hi Timothy, we’re working on a fix for that as we speak. I will update you as soon as possible.

    You can download and install the previous version by visiting https://wordpress.org/plugins/cardconnect-payment-module/advanced/

    Scrolling to the bottom of the page, and selecting the 2.0.18 version for download.

    Plugin Author RexAK

    (@rexak)

    @codearachnid,

    Please download/update to 3.0.1 and let me know your results.

    I also had the same problem. I was able to restore my site rolling back the update to a precious version to get me site working again.

    I have updated with 3.01 and did not get the 500 error, so appears to have been fixed.

    Will not know for sure until a customer tries to make a payment. Will let you know after the next CC paymment i tried.

    Thanks for your prompt response and fix for this problem.

    Plugin Author RexAK

    (@rexak)

    Thanks for the feedback @honolua808, it is greatly appreciated.

    I am getting this error as well and I’ve tried to roll back several times and nothing. Please help my site doesn’t work with this happening.

    I am also getting the invalid card issue on every transaction. When is this going to be fixed?

    Plugin Author RexAK

    (@rexak)

    @shurebusiness1973

    Make sure you have the latest PHP, WP, WooCommerce and CardConnect plugin.

    You’ll need to have version 3.0.3 of the CardConnect plugin.

    If the issue is not resolved by updating the plugin, please open a new support thread, so we don’t bug the original poster.

    If the issue IS resolved by updating, please post back and let me know.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘500 error upgrading to 3.0.0’ is closed to new replies.