Support » Plugin: Download Monitor » 500 Error since 4.0 Upgrade

  • Resolved nathanwells

    (@nathanwells)


    Ever since upgrading to version 4.0 all the downloads on two of my sites come up with a 500 error (I have three separate sites using the plugin). But if I am logged in as the admin, I can download all the files no problem. I am using ngix on Ubuntu. Any idea what could be causing this? My error logs aren’t showing me the 500 error and in Firefox all I get is a white screen of death.
    And on another of my sites everything works fine.

    I also noticed, that on the two sites where it is not working, the new “Reports” section of the plugin did not show up…I deactivated the plugin and reactivated it and then the “Reports” section showed up and works fine. But still none of the downloads work.

    • This topic was modified 4 years, 10 months ago by nathanwells.
    • This topic was modified 4 years, 10 months ago by nathanwells.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey Nathan,

    Can you please go to “Downloads > Settings”, then click on “Endpoints” tab, click save button and share a screenshot of that page?

    Also, please click on the “Access” tab and make sure a page is selected for the “No Access” option.

    Thread Starter nathanwells

    (@nathanwells)

    Sure, here’s the endpoint screenshot:
    https://ibb.co/bGaO4G

    and yes, I have a no access page selected.

    Thread Starter nathanwells

    (@nathanwells)

    In the meantime, is there anyway to go back to 3.x so my sites will work?

    Plugin Contributor Barry Kooij

    (@barrykooij)

    Hey Nathan,

    Did you run the upgrader after you’ve updated? If you want, I’d be happy to take a look at your website to see if I see what is going wrong. Please send us an email via https://www.download-monitor.com/contact/ if you do.

    Kind Regards,

    Barry Kooij

    Thread Starter nathanwells

    (@nathanwells)

    The updater did not show up automatically when I upgraded. I did manually go through it and no downloads needed updating, though it did update some pages.

    Thanks for your quick responses and willingness to help – I’ll send you an email.

    Plugin Contributor Barry Kooij

    (@barrykooij)

    Thanks, Nathan. We’ll chat more via email. Closing this ticket here.

    Thread Starter nathanwells

    (@nathanwells)

    I actually figured it out by looking at what was different in my server setups. Turns out it was because I was using HHVM on two of my servers (that didn’t work) while I was using PHP5 on the server that worked. I switched over to PHP5 and everything is working fine now.
    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘500 Error since 4.0 Upgrade’ is closed to new replies.