Support » Fixing WordPress » 500 Error only with Chrome

  • Resolved lpickard007

    (@lpickard007)



    Hi All,

    I have had an error 500 occurring when accessing one particular page on my website where I host all news and blogs. This error is only occurring in chrome on both mobile and desktop. If I use Firefox or IE this problem is not occurring.

    Any ideas on where I should or could be looking to resolve this issue?

    Thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator t-p

    (@t-p)

    – Please check the error logs on your server for a more specific error message and see why it’s failing. If you need help locating them, ask your hosting provider to help you with that.
    – If you cannot find error logs or if you don’t find any helpful info in the error logs, try Enabling debugging

    @t-p yes, i also thought it’s a server error, but nothing special showed up in the error logs.

    It’s a strange cookie problem in chrome and you have to clear all your cookies for your domain via the Dev Tools (not the normal Chrome settings page).

    For this, follow this guide:
    https://developers.google.com/web/tools/chrome-devtools/manage-data/cookies

    After that, relogin on your WordPress admin page and everything should be fine.

    Best regards,
    treehighroots

    Thanks for the answer here- I was having exactly the same problem! All good in browsers other than Chrome. Deleting the cookies for the domain, using Dev Tools, solved the problem.

    I am having the exact same problem. It started happening shortly after upgrading to version 4.8. However it is very strange. Mine was happening on any page, like home page. I found that if I went into the database and deleted the active add-ons record to deactivate all add-ons, that solved it. But then I re-enabled each add-on one by one and tested and none of them broke the system.

    A couple days later, Error 500 again. So I loaded Firefox, no Error 500. Went back to Chrome, cleared my cookies, Error 500 gone. Here’s the main concern though, I searched the Apache error log and the error is [core:error] End of script output before headers: index.php. I’m a developer and know how to track down Error 500 errors (or at least I thought so). There is no PHP error log showing the error and turning on Worpress debugging also created no log events. So I was never able to determine the cause.

    My BIG concern is if I search my logs I will find that same error but from other IPs which means other end users could be getting this error! A major disaster for my business this website is advertising if that is happening. Unfortunately Google Analytics isn’t going to give accurate 500 stats unless I create a custom error 500 page and add the analytics code to it I guess.

    Hi @consultant1027 I’m having similar since upgrading to 4.8. I leave my chrome open for days, with the cookie logged in (I tick the “keep me logged in” option). After a week or something, I get the 500 (or 502 on nginx). If I delete the “wordpress logged in” cookie in chrome, I’m immediately allowed back on.

    Please can I ask what theme and plugins you have?
    I have Divi theme
    Plugins:
    all in one seo pack
    anti spam
    cms tree view page
    comment link remove
    contact form 7
    cookie notice
    duplicate page
    font awesome 4 menus
    ithemes security
    lazy load for videos
    Meta Generator and Version Info Remover
    Monarch
    oik
    oik privacy policy
    plugins garbage collector (although I think I’ve had the problem on sites that this is disabled on)
    updraft plus
    use google libraries
    wp-page navi

    Maybe we can find some common denominator!

    Out of the plug-ins you listed I have:

    Divi Theme
    iThemes Security

    However as I mentioned, when I disabled all plugins, I could get back in, but then I renabled all plug-ins one by one and error 500 did not return! So I was unable to identify a plug-in causing it even though going into the wp_options table and deleting the active_plugins record to disable everything seems to fix it!

    So it seems if it is a plug-in causing it, disabling and re-enabling plugin also clears the problem.

    So next task when it happens again would be to disable plug-ins via database record, one by one.

    I think it happened on a non divi theme too, but I’ll double check my records tomorrow before stating that as fact.

    Would it work just renaming each plugin folder one by one in FTP, instead of playing in the database?

    Good point. I believe I read somewhere, that is another method to rename the folders. It would be the option for those who are not developers like myself familiar with using something like PHPMYAdmin to access the database.

    So for now the problem hasn’t resumed. Not sure if something updated to fix it (I have automatic non-core updates)

    I’m wondering if people in this discussion who have experienced the problem can confirm if the do or don’t have Divi Theme or iThemes security. If there’s even one user that does NOT have both of them and experienced the problem, that it would be a bug in WordPress 4.8. My suspicion is that it is iThemes security since disabling all plug-ins fixed the issue which would indicate it’s not a WordPress bug. Divi theme I don’t think is doing anything unusual with cookies. So that leaves iThemes Security. Maybe I will pose the question in the iThemes forum too.

    It just happened again for me and I can confirm it is indeed iThemes Security and only when using the Hide Backend feature, and only with Chrome as discussed here:

    https://wordpress.org/support/topic/hide-backend-causes-500-error/

    The Pro version has been fixed but not the free version yet which is strange.

    There are multiple temporary fixes – the keyword being TEMPORARY.

    – Clear Chome cookies (not recommended as other user’s using Chrome could experience the same issue (I suspect it might only have to previously logged in users but not sure.)

    – Rename better-wp-security folder in wp-content/plugins, login and go to plug-ins admin page, rename folder back, refresh plugins page

    NOTE: Simply deactivating and reactivating the plugin (via Firefox or Chrome with cookies cleared) did NOT fix the problem for me, only the folder rename method.

    PERMANENT FIX

    For now, I have disabled Hide Backend until I hear the Free version has been fixed.

    I like iThemes Security because I have other security (CSF LFD FIrewall) and needed a solution that I can configure to be lightweight and not duplicate security functions I already have but to be honest I have seen many strange themes with this plugin in the 5 months I’ve used it like this error and getting database backup emails, 5 in a row, when I have database backup disabled and have not made any settings changes. It is worrisome when a security plugin is behaving inconsistently!

    I’ve never had any issues with iThemes until this.
    Thanks for the link. The hide feature is so useful. Hope sorted soon.

    @t-p, Thank you! It works for me 🙂 The problem was only with admin panel and my computer. None of my colleagues and clients complained

    • This reply was modified 1 year, 2 months ago by  galinaivvn.

    I confirm that removing the rule on htaccess for the rewrite of hide admin panel now works without problems.

    Moderator t-p

    (@t-p)

    @galinaivvn, @mte90,

    Glad you got it sorted 🙂

    Please note it has been over 2months since the OP replied.

    Side note to those who are still having problem: If the troubleshooting already posted made no difference for you, then, as per the Forum Welcome, please post your own topic.

    This thread is closed now.

    • This reply was modified 1 year, 2 months ago by  t-p.
Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘500 Error only with Chrome’ is closed to new replies.