Support » Installing WordPress » 500 Error installing 2.3

  • I am having issues getting 2.3 to run. My first effort was an upgrade of a newly installed 2.2 version. I had not even had the chance to upload themes or anything to this install before 2.3 came out. So I followed the upgrade procedure and got a 500 error right out the gate firing upgrade.php. After a few other aborted attempts I replaced the 2.3 files with the 2.2 code and the site came right up and runs fine on 2.2.

    Just a short tiime ago I attempted an install of 2.3 to a brand new domain. I get a 500 error on that site as well when running install.php. How can I figure out what might be causing the 500 error? There is obviously something different between 2.2 and 2.3 that can cause this issue, but I have found nothing in the documents.

    Thanks,
    Kent

Viewing 15 replies - 1 through 15 (of 25 total)
  • Check your logs, you may need to increase memory available to PHP–if so talk with your host.

    I am getting the error:
    ALERT – canary mismatch on efree() – heap overflow detected (attacker ‘67.160.110.95’, file ‘/hsphere/local/home/kentogle/kentogletree.com/wp-includes/taxonomy.php’, line 11)

    Wow, a google search of that tells me you better talk to your host!

    http://www.google.com/search?q=canary+mismatch+on+efree

    A quick read does indicate lead one to believe that, however an indepth read shows that the Suhosin Patch to the installation caught an attempt by the script to free memory that had already been freed. The Suhosin Patch is actually intended to catch these types of attempts.

    So I guess it is back to 2.2 for me.

    I have limited time to chase issues and try to come up with a solid bug report. However here is what I have done and I get the same results very time.

    Running on FreeBSD 6.1 and PHP 5.2.2 with the Suhosin Patch I get a 500 error firing the Install.php on a new install or upgrade.php on an upgrade. This occurs on 4 different servers with 2 different hosting providers with simuler configurations. It also occurs on a PHP 5.2.4 installed server also running FreeBSD that a friend manages. I see quite a few other reposts in these forums and blogs about 500 Errors, so I am not the only one seeing these issues.

    The previously cited google search mostly centers around reports for PHP 4.x, citations againest PHP 5.x show the issues turned out to be with the script from the ones I read.

    Kent

    Hi Kent,
    it’s not much help I know, but I am having the exact same problem, again on a FreeBSD server, again with the Suhosin patch (apparently it comes by default with FreeBSD?) If you’d like we can compare phpinfo’s and see what else we have in common?

    I’m having intermittent “500 Internal Server Error” issues with my 2.3 install with phpwebhosting.com

    mattmmatt – what are your log files saying?

    MichaelH – on my shared host I only can see the access log, which did not mention the error.

    Now the wild thing is, I spent quite some time working on the problem last night to no avail. This morning I find that the site seems to be running fine.

    #update
    I simply downloaded and expanded a new plugin in the plugins folder, and when I went to activate I encountered the error again. Now the error is happening frequently on my site again.

    Last night I saw people with issues with PHP memory. It appears my PHP install max memory is at 32M, which seems to be quite above anyone else needed. Hrm.

    Same exact problem here. I installed v2.3 on FreeBSD with hsphere and it doesn’t seem to want to work spittng out the same error code you get.

    I also installed v2.2.3 and that works just fine albeit sloooooow to load most of the time. Maybe there’s a page caching plugin to fix that issue i can play with. I may have to go down to v2.2 which is working perfectly on a different domain but same server.

    So it looks like something critical did indeed change between 2.2 and 2.3. The question still remains though….what?

    Somehow I don’t think it’s a flaw in php itself….if wordpress is built to hog that much memory, well, that may be something to look into for new versions?

    I am having that dreadful problem with heap overflow too, didn’t notice when it started though, most likely with the upgrade to WP 2.3. My domain logs show these errors:

    [Thu Nov 22 10:22:27 2007] [error] ALERT – linked list corrupt on efree() – heap corruption detected (attacker ‘65.111.210.184’, file ‘/usr/home/username/domainname.com/htdocs/wp-settings.php’, line 190)
    [Thu Nov 22 10:23:38 2007] [error] ALERT – linked list corrupt on efree() – heap corruption detected (attacker ‘201.141.145.223’, file ‘/usr/home/username/domainname.com/htdocs/wp-settings.php’, line 192)
    [Thu Nov 22 10:23:55 2007] [error] ALERT – linked list corrupt on efree() – heap corruption detected (attacker ‘88.131.106.6’, file ‘/usr/home/username/domainname.com/htdocs/wp-settings.php’, line 197)

    The errors do not happen all the time, in fact i can’t find any patterns (can happen 10 times in 15 minutes, then nothing for the next 2 hours). Sometimes i even find my own ip in the logs, which is telling me it is not bot attack or something. Notice it’s a different line of wp-settings.php every time that is causing the error.

    Each time an error occurs apache most likely hangs and the server becomes very slow for some time, or until apache’s graceful restart. PHP memory has been upped to 16, 24 and 32 mbs and it didn’t help. Tested this on two different servers with two different PHP versions (4.4.4 and 4.4.7), only to the same result.

    Currently i use wp 2.3.1 with custom theme and 3 plugins (WP-PageNavi, Peter’s Custom Anti-Spam and Kottke Style Archive), all others that used to run fine before were disabled until i can fix the error.

    I can’t believe noone else is having such problems. I have tried almost anything that was recommended, but to no avail. Shall i try to recompile PHP without Suhosin patch?

    settip up a cron job to restart apache every 30 minutes seems to have helped. But isn’t it kind of not right way to solve problems?

    reinstalled php with no Suhosin patch. The errors stopped appearing, but the system is still slow

    OK, I have an update on this.

    My hosting is FreeBSD 6.1, PHP 5.22 w/ Zend2, Suhosin Patch v0.9.6.2, and Apache 1.3.3.7. Given that WP 2.2.x works fine on this, I assume I’m meeting minimum requirements.

    I have a test subdomain with an .htaccess file with the following contents to override my hosting defaults:
    php_value memory_limit 32M
    php_value post_max_size 16M
    php_flag display_errors on
    php_flag suhosin.cookie.encrypt Off
    php_value suhosin.request.max_vars 2048
    php_value suhosin.post.max_vars 2048

    I’m trying to give php some more memory to work with as suggested elsewhere in WP support while getting suhosin to back off a bit: this is a vbulletin hack for the same sort of 500/blank screen issue. I have tested with default perms, recursive 644 and recursive 755 all with the same results. I tried with both a hand coded wp-config.php and a wordpress generated one.

    After some teething problems with missing files where the php display errors helped out, I was back to a 500 Error. Checking the error logs it seems that Suhosin really doesn’t like what wordpress is doing:

    ALERT – canary mismatch on efree() – heap overflow detected (attacker ‘203.110.28.91’, file ‘/hsphere/local/home/whetu/test.rawiriblundell.com/wp-includes/taxonomy.php’, line 11)
    [Wed Dec 26 18:32:27 2007] [error] [client 203.110.28.91] Premature end of script headers: /hsphere/local/home/whetu/test.rawiriblundell.com/index.php

    Commenting out line 11 of wp-includes/taxonomy.php like so:
    // $wp_taxonomies[‘category’] = (object) array(‘name’ => ‘category’, ‘object_type’ => ‘post’, ‘hierarchical’ => true, ‘update_count_callback’ => ‘_update_post_term_count’);

    will get wordpress installed and working, however it will be littered with errors. Removing the error display line from .htaccess will probably resolve this, however I doubt WP will function properly.

    As far as this issue goes, the WordPress devs have dismissed it as not their problem:
    http://trac.wordpress.org/ticket/5228

    Interestingly though, WP 2.2.x has exactly the same line of code in wp-includes/taxonomy.php yet WP 2.2.x appears to install and work fine. Note also that I have php 5.2.2 which should have the suhosin fix mentioned in the thread that the WP devs linked to when dismissing this problem. You may now raise one eyebrow and stroke your chin as if you are intruiged.

    It’s clear though, looking around WP support, that multiple people have this issue, and I bet that they’re on different server configurations than me, and that like me, they or their hosting providers won’t be entirely incompetent at setting up php with suhosin. So maybe this could warrant a closer look… or not.

    I know very few people who can run v2.3. I can’t upgrade ANY of my blogs past v2.2.2 becuase of this 500 Server error. And that’s on different server configs.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘500 Error installing 2.3’ is closed to new replies.