WordPress.org

Forums

Google Analytics Dashboard for WP
[resolved] 500 Error during setup (8 posts)

  1. uk_martin
    Member
    Posted 1 year ago #

    Any idea why I get a "500 Error" when trying to save my Google Analytics Dashboard Access Code? This is the URL that's producing the error instead of

    http://www.birminghambrummies.co/wp-admin/?ga_dash_code=4%2F...(many letters and numbers)...Hx0gQI&ga_dash_authorize=Save+Access+Code#

    The instructions that I'm following are here - http://www.deconf.com/en/projects/google-analytics-dashboard-for-wordpress/ - and I get as far as 2:30 mins into the video but instead of the dashboard appearing, I get the URL above.

    I know that the server is a Windows IIS Server, whether that has anything to do with it. Is it something that I can resolve or does the host have to do anything for me?

    Kind Regards

    Martin

    http://wordpress.org/plugins/google-analytics-dashboard-for-wp/

  2. Alin Marcu
    Member
    Plugin Author

    Posted 1 year ago #

    Can you check if cURL is installed on your server, use this code in a test.php file:

    <?php
    
    phpinfo();
    
    ?>
  3. uk_martin
    Member
    Posted 1 year ago #

    Hi

    Thanks for the reply. cURL does appear to be installed.

  4. uk_martin
    Member
    Posted 1 year ago #

    Don't know if this helps, but I've found out the following:

    cURL version 7.16.0
    cURL SSL version OpenSSL/0.9.8g

  5. uk_martin
    Member
    Posted 1 year ago #

    Just to confirm that the 500 error occurs whether I try the basic setup, or if I try the advanced setup creating my own API Project Credentials.

    Either way, as soon as the access code is entered in the Dashboard, not only does the Saving of the access code result in a 500 Error, but the dashboard (wp-admin/index.php) is locked out with a 500 Error until such time as the authorisation is cleared in the GA-Analytics Settings page.

    I hope that someone may be able to help me with this...

  6. Alin Marcu
    Member
    Plugin Author

    Posted 1 year ago #

    Look in php.ini and tell me the value of memory_limit, also try to increase the memory limit to a higher value.

    If you can set permissions you should also try to give write permissions on wp-content to IUSR

    Also make sure that IUSR has write permission on the path specified in error_log, in php.ini.

  7. uk_martin
    Member
    Posted 1 year ago #

    Sorry if this sounds stupid, but where do I find the php.ini file on a Windows IIS server?

    Not that I think I need it right now, but just out of curiosity, and for future reference. As it is, giving write permissions to IUSR has solved the issue.

    Thank you very much for your help.

  8. Alin Marcu
    Member
    Plugin Author

    Posted 1 year ago #

    Usually, on shared hosting, you don't have access to that file. It depends on your hosting provider, server configuration and your hosting plan.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Analytics Dashboard for WP
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic