Support » Plugin: Appointments » 500 Error Allowed Memory Exhausted / Latest version

  • Resolved Mike Price

    (@castroboy)


    Hey there,

    The latest version of your plugin is causing a 500 error specifically a memory issue on the Book Appointment page as well as in the backend when trying to add a new service.

    Examples:

    PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /salon/wp-content/plugins/appointments/includes/class-app-appointment.php on line 31

    When I rolled back to previous version 2.27, it works just fine as expected with no other changes to the plugins or themes etc.

    Memory issues are so vague and hard to replicate but I was told via your Twitter team to post about it here after trying the previous version of the plugin. Thanks.

    = Mike

    • This topic was modified 2 years, 11 months ago by Mike Price.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @castroboy,

    Hope you’re well.

    Sorry to hear that problem, but it’s not expected thing. Maybe with the latest version, there can be some conflict between plugins. Did you try conflict tests? If not, can you deactivate all plugins and only try with Appointments plugin? Is problem continues? If it solves, please activate plugins one by one until replicate, so we can understand which plugins conflicting. Also, if it doesn’t solve please try activating default Twenty Seventeen theme.

    If conflict test doesn’t give any progress, can you check WordPress debug logging too? You need to place these codes in your wp-config.php file;

    /* Debug Settings */
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    /* End of Debug Settings */

    Then recreate the issue on the frontend. And check the wp-content folder, is there any debug.log file? If yes please share the content with us.

    Cheers,
    Oguz

    I am also now having this same issue. From this page, when you select the service provider, the site gives you a HTTP 500 error.

    Plugin Contributor Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @mcatselfprep

    Please access your server through (S)FTP, edit the wp-config.php file and insert the following line just above the /* That’s all, stop editing! Happy blogging. */ comment
    define('WP_MEMORY_LIMIT', '512M');

    If this continues for you, please create a separate topic and we will carry on from there.
    Reference:
    https://make.wordpress.org/support/handbook/forum-welcome/#post-in-the-best-place

    Warm regards,
    Dimitris

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @mcatselfprep

    I trust you’re well!

    We’ve not heard from you in a while. I’ve marked this ticket as resolved for now, but if you need anything else at all, we’re here for you, please just reopen the ticket or create a new one.

    Have a good day!

    Cheers,
    Nastia

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘500 Error Allowed Memory Exhausted / Latest version’ is closed to new replies.