500 Error after updating to 3.4 (15 posts)

  1. Frans Andersson
    Posted 3 years ago #

    After updating to WP 3.4 we are experiencing a 500 error when activating a theme on sites in our installation. The error occurs no matter which theme we activate. Even though we get an error, the activation goes thru OK as far as we can tell, but we have not studied the database closely yet.
    Can anyone help shine some light on this problem?

  2. Frans Andersson
    Posted 3 years ago #

    I just looked at the apache log. The error leaves this comment: PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 79 bytes) in /www/wp-includes/wp-db.php on line 1449, referer: XXXXXXXX/wp-admin/themes.php?s=qual&_ajax_fetch_list_nonce=24b2fce649&_wp_http_referer=%XXXXXXXXXX%2Fwp-admin%2Fthemes.php%3Fs%3Dqu%26_ajax_fetch_list_nonce%3D24b2fce649%26_wp_http_referer%3D%252FXXXXXXXX%252Fwp-admin%252Fthemes.php

    Obviously it is a memory error but it does not seem right that this script uses 256 MB of RAM for one single operation...

    (I have X’ed out some information in the string above).

  3. Something's eating up the available memory, 256MB is huge.

    Using Twenty Eleven as your theme, deactivate all the plugins and then try activating the theme.

    Also can you post a link to your theme and/or site?

  4. Frans Andersson
    Posted 3 years ago #

    Hi Jan, Thanks for pitching in!
    The site is a big multi site installation with 400+ sites and 50+ themes.

    I have tried creating a new site with no plugins activated, no content and it still throws the error. The maine site plugins are still active (domain mapping + blog template) but unfortunately, it is not an option to deactivate those plugins. Suffice to say that this has not been a problem before we updated to V 3.4.

    It doesn’t matter witch theme we try using. All of them create the same error. Most of the themes are tiny ones with very few features. Even twenty ten / eleven are affected.

  5. That's... intimidating to say the least. ;)

    It's probably not practical to do so, but if you can duplicate the setup on another server (oh yeah, 400+ sites!) and replicate the same condition then you can try to isolate the cause.

    I'm thinking it may also be a theme but replicating the issue is the real challenge.

  6. ravikumar2266
    Posted 3 years ago #

    I also have my website on wordpress(http://www.cyberkingmedia.com/) I made it few months back. I saw wp 3.4 update and I tried to update it and I lost my website. Now my website shows fatal error and the exact message was

    Fatal error: require() [function.require]: Failed opening required '/home/a8941041/public_html/wp-includes/class-wp-theme.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a8941041/public_html/wp-settings.php on line 115

  7. ravikumar2266
    Posted 3 years ago #

    Now what would you suggest me guys what should I suppose to do now?

  8. @ravikumar2266, my suggest to you would be this: Please open up your own thread. It's considered impolite to intrude on someone else's.


    Your problem is not related to the OPs.

  9. Frans Andersson
    Posted 3 years ago #

    I'm sorry ravikumar, but that question is better asked in the regular WP forum and not in this thread. Hope you find the answers you are looking for!

    @Jan: We already have a testing environment set op for situations like this. I am currently transferring the system to this testing environment. My thinking is that we have a memory leak somewhere but there is no telling what causes it.

  10. wpfranner - What server specs have we got? Memory and CPU, but also what version of PHP.

  11. Frans Andersson
    Posted 3 years ago #

    16 Gb RAM
    2.40 GHz Xeon
    PHP Version 5.3.2
    average serverload is <60 %

    The server is ONLY serving this wordpress site and nothing else. No virtualisation, no shared hosting. Just this.

  12. Frans Andersson
    Posted 3 years ago #

    Problem solved and plugin bug found (maybe).
    @Ipstenu a few weeks ago you helped me find a "theme info" plugin: http://wordpress.org/support/topic/multi-site-theme-lookup-list
    The plugin worked perfectly and no errors occurred when activating themes on sites. After updating WP to 3.4 however, the memoryleak (or whatever causes the 500 error) started showing up. Now I have removed the plugin from the file system and the error does not occur at all.

    BUT: I have tested the plugin on a private WP MU server that runs on shared hosting (PHP Version 5.3.9) and here the error cannot be replicated. Granted this server does not have nearly as many active sites as the original server so maybe that is part of the puzzle.
    Should a bug report be submitted to the plugin author?

  13. xzoom
    Posted 3 years ago #

    Before upgrading the production version, you should try on a test server.

  14. Frans Andersson
    Posted 3 years ago #

    We did, but somehow missed this error.

  15. Should a bug report be submitted to the plugin author?

    Always :) Post here: http://wordpress.org/support/plugin/wpmu-theme-usage-info

    xzoom - Sometimes errors only show up when you use it live, because of the amount of traffic/CPU on the real box.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.