Support » Plugin: WP Security Audit Log » 500 error after updating to 3.3

  • Resolved ZigPress

    (@zigpress)


    I have this plugin plus some premium addons installed on a site:

    WP Security Audit Log 3.2.5
    Email Notifications for WP Security Audit Log 2.2.2
    External DB for WP Security Audit Log 1.2.0
    Reports for WP Security Audit Log 2.1.2
    Search for WP Security Audit Log 2.0.1
    Users Sessions Management for WP Security Audit Log 1.0.6

    Updating this plugin to 3.3 causes a 500 internal error. My error log says:

    PHP Fatal error: Uncaught Error: Call to a member function AddPremiumPlugin() on null in /home/XXXX/public_html/wp-content/plugins/email-notifications-wsal/email-notifications-wsal.php:90

    and

    PHP Fatal error: Uncaught Error: Call to a member function IsEnabled() on null in /home/XXXX/public_html/wp-content/plugins/email-notifications-wsal/email-notifications-wsal.php:252

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor robertabela

    (@robert681)

    Hello @zigpress,

    Thank you for reaching out.

    The problem are the version of the add-ons you are running. They are old and you need to migrate to the new edition. Since this request is about the premium edition please contact us via email on support@wpsecurityauditlog.com.

    This forum is for supporting the free edition of the plugin.

    Looking forward to hearing from you.

    OK, thanks. My client has the login for the premium addons, so I’ll get them to download the latest versions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘500 error after updating to 3.3’ is closed to new replies.