Support » Plugin: Caldera Forms - More Than Contact Forms » 500 Error after update

  • Resolved Michael

    (@otkwebmaster)


    I had to deactivate the plugin after the latest update as activating it generates a http 500 error. The prior version worked just fine. Our server is running php 7.0.30. Any ideas?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • I have the same problem. As soon as I updated the plugin, my site crashed.

    I got similar problem which mine seems it crashes with Ultimate Member plug in, my suggestion is try to remove all of your plugin and try to install one by one

    In my case, it seems I have to deactivate the caldera forms in current latest version

    The problem is with the front-end flushing rewrites request

    How to downgrade to previous versions?I still can’t

    This the issue that i had after update the plugin 13 hours ago

    Fatal error: Uncaught Error: Call to undefined function get_home_path() in /home/users/hompimpa/apps/doremi/public/wp-admin/includes/misc.php:204 Stack trace: #0 /home/users/hompimpa/apps/doremi/public/wp-includes/class-wp-rewrite.php(1775): save_mod_rewrite_rules() #1 /home/users/hompimpa/apps/doremi/public/wp-includes/class-wp-hook.php(286): WP_Rewrite->flush_rules(true) #2 /home/users/hompimpa/apps/doremi/public/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /home/users/hompimpa/apps/doremi/public/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home/users/hompimpa/apps/doremi/public/wp-settings.php(471): do_action(‘wp_loaded’) #5 /home/users/hompimpa/apps/doremi/public/wp-config.php(37): require_once(‘/home/users/serv…’) #6 /home/users/hompimpa/apps/doremi/public/wp-load.php(37): require_once(‘/home/users/serv…’) #7 /home/users/hompimpa/apps/doremi/public/wp-blog-header.php(13): require_once(‘/home/users/serv in /home/users/hompimpa/apps/doremi/public/wp-admin/includes/misc.php on line 204

    Same problem here. Server is running php 7.1. I have also installed the ultimate member plugin.

    Same issue here, but not using Ultimate Member plugin. Here’s the error:

    2018/06/02 08:37:14 [error] 12383#12383: *638150 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Class 'calderawp\calderaforms\pro\container' not found in /home/forge/domain/production/public/content/plugins/caldera-forms/includes/cf-pro-client/bootstrap-cf-pro.php:48
    Stack trace:
    #0 /home/forge/domain/production/public/wp/wp-includes/class-wp-hook.php(286): {closure}('')
    #1 /home/forge/domain/production/public/wp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #2 /home/forge/domain/production/public/wp/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #3 /home/forge/domain/production/public/content/plugins/caldera-forms/caldera-core.php(83): do_action('caldera_forms_i...')
    #4 /home/forge/domain/production/public/wp/wp-includes/class-wp-hook.php(286): caldera_forms_load('')
    #5 /home/forge/domain/production/public/wp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #6 /home/forge/domain" while reading response header from upstream, client: 162.158.154.9, server: domain, request: "GET /ambassador-program HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.2-fpm.sock:", host: "domain", referrer: "https://domain/"

    I’m on PHP 7.2.

    Michael

    (@otkwebmaster)

    I am also using Ultimate Member, but to clarify, I was using Ultimate Member before this update to Caldera Forms and everything was working swimmingly. As of this moment, several forms we use are unavailable. 🙁

    I also use Ultimate Members. And I have the same mistake.
    Please correct this error that the forms are working.

    Same problem here – could not access the admin panel. My host support deactivated the plugin, so I am back up and running, but with no forms!

    Same Problem – i’m using Pods – Custom Content Types and Fields

    Fatal error: Uncaught Error: Call to undefined function get_home_path() in C:\xampp\htdocs\lm_neu\wp-admin\includes\misc.php:204 Stack trace:
    #0 C:\xampp\htdocs\lm_neu\wp-includes\class-wp-rewrite.php(1775): save_mod_rewrite_rules()
    #1 C:\xampp\htdocs\lm_neu\wp-content\plugins\pods\classes\PodsInit.php(1146): WP_Rewrite->flush_rules()

    Same problem for me, I’m using Ultimate member with Caldera. Initially I thought that was a problem with Ultimate member, but it’s not true. The only problem is caldera.. after update. What should we do, or how we can downgrade to the previous version of caldera?

    Michael

    (@otkwebmaster)

    A brand new install killed another site I manage, so it is not just an update issue. And yes, another site with UM installed.

    Same here
    I originally think it’s the problem of Ultimate Member
    The site resumed when I stopped Ultimate Member, but the site still have some problem that, when I switched the theme, Error 500 appeared again (but resumed after a reload).

    Then I stopped all plugins, and restarted one after one.
    It turned out it was Caldera Form

    To summarize:
    Both Caldera Form and Ultimate Member — crash
    Caldera Form Only — the site works, but Error 500 when changing the Theme
    Ultimate Member Only — everything is fine

    Michael

    (@otkwebmaster)

    If anyone wants to go back to the previous version, which was working fine with my site, you can get it here

    https://wordpress.org/plugins/caldera-forms/advanced/#download-previous-link

    At the very bottom of the page – version 1.6.3

    Thanks Michael for your link.
    But will the “previous version” overwrite all the settings of my forms?

    M

    (@angelxchild)

    I just tried manually replacing the plugin files with version 1.6.3, and while it fixed the 500 error, I lost my form settings. Luckily I was able to restore everything with a backup!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘500 Error after update’ is closed to new replies.