Support » Installing WordPress » 500 blank page wp-admin/install.php docker (php8,mysql,nginx)

  • I do have mysql,nginx and php in docker. When i run wp-admin/install.php it returns 500 internal server error on

    in function is_blog_installed
    $installed = $wpdb->get_var( “SELECT option_value FROM $wpdb->options WHERE option_name = ‘siteurl'” );

    (wp-settings@line 159+- wp_not_installed function -> is_blog_installed function

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator bcworkz

    (@bcworkz)

    is_blog_installed() is a multisite only function. install.php needs to be run as a single site installation first. Only after installation should multisite be enabled.

    Do you have an old MULTISITE definition on wp-config.php? If so, make it into a comment before running install.php

    glamourpunk

    (@glamourpunk)

    Currently debugging the same issue.

    is_blog_installed() doesn’t seem to be a multisite only function in the way described, it looks like it gets called in wp-includes/load.php on line 752 if is_multisite() is falsy.

    Will report back here if I figure it out!

    glamourpunk

    (@glamourpunk)

    Ok figured it out. So in my case I was using PHP8.1, and it doesn’t look like WordPress (currently 5.8.2) is quite compatible with it yet.

    Specifically the wp install fail is related to this issue:
    https://core.trac.wordpress.org/changeset/51582

    So the solutions are:
    1. Add the change manually to wp-includes/wp-db.php (I guess there could be other wp@5.8.2/php@8.1 incompatibilities though so YMMV) – i.e. mysqli_report(MYSQLI_REPORT_OFF); on line 1631.
    2. Go bleeding edge and try the WordPress 5.9 beta
    3. Downgrade to php 8.0
    4. Wait for the next WordPress release.

    Hope that helps!

    • This reply was modified 6 months ago by glamourpunk. Reason: added the specific code from trac
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘500 blank page wp-admin/install.php docker (php8,mysql,nginx)’ is closed to new replies.