Support » Plugin: Shortcoder β€” Create Shortcodes for Anything » 5.X doesn’t allow other shortcodes

  • Resolved codimex

    (@codimex)


    Hi Aakash.

    Really sad to say that, before the 5.X version, your plugin was perfect. It allowed me to use other plugins’ shortcodes (for examples, those created with “Custom Content” plugin) in the code editor, creating awesome dynamic bits of information. Now, with the new update, I’m not able to do it anymore. Is it due to HTML escaping new feature?

    Please, enable back the ability of using other plugin’s shortcodes in the code editor. To me, 5.X version sadly represents a step back. This is one of my favourite content-fetcher plugin, and this feature is essential for more advanced users.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author vaakash

    (@vaakash)

    Hi @codimex,

    There is no restriction as such. You can insert other shortcodes in shortcoder content.

    Can you please specify in detail what beahviour you are seeing ?

    Thanks,
    Aakash

    Hi Aakash,

    same here, e.g. this visual composer (formerly wpbakery) shortcode [vcex_divider style=”solid” icon_color=”#eeeeee” icon_size=”14px” margin_top=”0px” margin_bottom=”0px”] doesn’t work inside your code with version 5.01, back to 4.6 works fine.

    With 5.01 you see the whole “vc raw code” in the frontend.

    Thanks in advance

    Olli

    • This reply was modified 9 months, 2 weeks ago by ollimil.
    • This reply was modified 9 months, 2 weeks ago by ollimil.
    Plugin Author vaakash

    (@vaakash)

    Thanks for reproting. I’m aware of this issue. I’ll issue a fix ASAP today

    We have to thank for your great work πŸ™‚

    Regards

    Olli

    Plugin Author vaakash

    (@vaakash)

    Hi,

    Update 5.0.2 fixes this issue. Please update to it.
    Please confirm if it solves your issue.
    Sorry for inconvenience !

    Thanks,
    Aakash

    Hi! Thank you for your fix! Yes! 5.0.2 fixes that, but javascript scripts still don’t work. Do you have plans for including js back to the plugin?

    Plugin Author vaakash

    (@vaakash)

    Hi @codimex,

    “but javascript scripts still don’t work.”

    Can you please explain in detail ?

    Hi again, Aakash. Thanks for your quick response and your readiness to help. Let me elaborate. Before 5.X I used to have js codes after my regular HTML, inserted like this:
    <script type="text/javascript"> My js script </script>
    But now, they don’t work anymore, and the js script are rendered as a regular text. Am I still allowed to include js scripts under the < script > HTML tag? 5.0.2 version solves the shortcode issue (thanks again!!!) but not the js thing.

    Plugin Author vaakash

    (@vaakash)

    @codimex,

    There is no restriction as such. I’m trying to figure out what might be the issue.

    I’ll get back to you shortly.

    Thank you again for yor answer. Let me show you an example of an API-generated Google Map with your plugin in one of my websites. It is rendered by means of an embedded js <script type="text/javascript">...</script> in a shortcode (see attached screenshot):
    https://paste.pics/7OW5I
    After the update, the map just doesn’t render (just a blank line; no need to attach the screenshot). I’ve rolled back to 4.6 until we can figure out what’s going on.
    Thank you for your patience with us users after this critical update. I look forward to your answer!

    Plugin Author vaakash

    (@vaakash)

    @codimex I do not see this issue in my setup nor able to reproduce this.

    I look forward to fix the issue but cannot proceed without more details.

    Can you please send your website address, a temporary administrator username and password to my email ?
    aakash [dot] 19493 @gmail.com

    This should help me find the issue live.
    Thanks for your time.

    Hi again! Thank you so much for opening your personal email to me. Let me do a few tests more, because the main site shows errors, but a mirror site I have of the same website doesn’t show errors, which is pretty weird and nonsense.

    In the meantime, let me rate you with 5 stars for all the hard work behind this plugin and your readiness to help.

    Plugin Author vaakash

    (@vaakash)

    @codimex,

    Thanks for your support !

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘5.X doesn’t allow other shortcodes’ is closed to new replies.