Support » Installing WordPress » 5-Minute Installation Pains

  • Resolved Toosheds


    I am a new to WordPress and am having great difficulties with the installation on my local Windows machine (Window 7). I followed the instructions for the 5-minute installation, but keep getting a database connection error when trying to install WordPress via the Microsoft Web Platform: “access denied for ‘root’@’localhost’ (using password: YES).

    During installation I used the Default Web Site on page 1 and created a new database on page 2, using all the defaults and simple passwords for the admin and user accounts. I have tried all the possible combinations of default and new on both pages but keep getting the same error.

    Here is a complete history, as I feel something here might have some relation to the problem:
    – Before deciding on WordPress I had looked into Joomla, and had installed both XAMPP and Joomla.
    – There was a hitch installing the Microsoft Web Platform, (perhaps because of XAMPP?), but that seemed to work out when I installed SQL server independently, following instructions from a thread in the MS forum.
    – I have uninstalled XAMPP, but the problem still exists.
    – Wanting to get a feel for WordPress, I installed the Bitnami Native Stack Installer, but the management tool for phpMyAdmin will not accept the name and password I set up during installation.
    – When installing Bitnami, Port 80 was not available.

    I am not a developer but have experience with the backends of both Typo-3 and Joomla. I plan on creating several WordPress sites, so I am eager to get started.

    I appreciate all help!


    p.s. Since I have several sites to create and may likely create many more in the future, I would like to know if using a dedicated (internal) hard drive to use as my development web server would be good idea. If so, how do I completely uninstall Microsoft Web Platform and all the components it installed from my C: drive to make a clean start on the dedicated drive? Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I think i found your problem, disable the Microsoft Web Platform, because wordpress and microsoft don’t look or work good togeather and re-install xampp in the C:\xampp location,
    open the xampp control panel and make sure that “svc” is checked off next to apache and mysql then choose start next to apache and mysql
    by default there is no password for root at mysql to learn how to set or change this click here:
    after all of this there should be no issues

    Thanks for the quick reply, Alex and Anthony. Three questions, though:

    – How do I disable the Microsoft Web Platform?
    – If the Platform is disabled, does the installer still work?
    – After I get the XAMPP and MySQL worked out as you suggest, do I install WordPress via the web Platform Installer or use the one installed with Bitnami (I installed that tot he dedicated drive already)?


    you can stop Microsoft Web Platform by doing this:
    1. open the command prompt as administrator
    2. in the command prompt window type “net stop w3svc” and then type “net stop iisadmin” without quotes, or you can uninstall Microsoft Web Platform altogether.

    and after you get xampp and mysql running, use these instructions to install wordpress its simple and easy,

    Did all the following, but the installer still cannot create the WordPress database – I get the same error message as before.

    – Tried “net stop w3svc” but was not allowed access (Windows 7 permissions BS??).
    – Tried “net stop iisadmin” but the service was not found.
    – to be safe, uninstalled everything from the Microsoft Web Platform Installer that I had previously installed. Everything uninstalled except one piece of Microsoft SQL sever 2008 R2.
    – Reinstalled WAMPP
    – Checked the svc next to Apache and MySQL
    – Started Apache
    – Tried to start MySQL. First the log says “busy”, then it says “MySQL service started”, but the “running” indicator does not show up, the Start button does not turn to “Stop”, and the Admin button does not highlight (all as for Apache).
    – Decided to install WordPress anyway, and still get the database error messsage. Tried creating a new database and using the existing one, and got the same message. The installer requires an admin password when creating anew database, by the way. I had no idea what to put here, so entered “password”.
    – This time I just installed WordPress and its dependencies, nothing else. Should I have also installed the MySQL Windows Essential 5.1 and Windows Cache Extension 1.1 for PHP 5.2 which were included on the install page but not listed as essential?

    The install log says “The database ‘wordpress’ could not be created.”

    Is something is wrong with my MySQL? Could it be that something left over from my origianl XAMPP installation or something else is interfering? If so, how would I go about flushing all MySQL from my C: drive and starting over?

    Thank you for your patience.

    Problem solved. I removed everything, ran CCleaner, installed XAMPP on my dedicated drive (not drive C:), then installed WordPress following this tutorial.

    Works great!

    Appreciate the help.

    You’re welcome!

    Well, now I have another problem. Not sure if this should be in a new thread or not. Everything was fine until I restarted my computer. here is what happened:

    1. Apache would not start (may be a McAfee firewall issue) so I changed port 80 to port 81 in the httpd.conf file. Apache then started fine.
    2. Neither phpMyAdmin nor WordPress would start, so I changed the URLS as follows:

    to: http://localhost:81/phpmyadmin/
    to http://localhost:81/wordpress/wp-admin/

    phpMyAdmin started fine, but wordpress did not. I get a 404.

    I tried adding index.php, but no difference. Do I have to change the path in some file for WordPress to be found?

    Thanks again!

    I meant to say that I cahnged the wordpress path to:


    your issue is probably a mcafee problem, but you should try to remove “htdocs” from the path on wordpress to “http://localhost:81/wordpress/wp-admin/” and try that

    if you want other people to see your site, try opening that port in your router too.

    Turns out that McAfee is blameless – IIS was the culprit. I turned of the WWW Publishing Service in Windows and now everything is back to normal (port 80). Went that route after all attempts to call up WordPress under port 81 were futile.

    This is just a development server where I plan on learning WordPress, though I will later likely build my sites locally and then move them to my server.

    Once again, many thanks!

    Toosheds how did you use ccleaner to help get rid of problems?
    I’m thinking I’ve got leftover files as well and I have just uninstalled every iis feature I can find.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘5-Minute Installation Pains’ is closed to new replies.