Support » Fixing WordPress » 5.8 t.onChangeSectionExpanded is not a function at customize-widgets.min.js:2

  • Resolved ab6499

    (@ab6499)


    My site has updated to 5.8. Now the customize no longer opens, this below is the error message reported in the console. Thanks for any help.

    “Uncaught TypeError: t.onChangeSectionExpanded is not a function
    at customize-widgets.min.js:2”

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hey @ab6499

    It could be a compatibility problem between 5.8 and one of the plugins or themes you have installed – would you mind providing a list of the plugins and themes you use?

    I found a Gutenberg issue that looks somewhat related. It isn’t directly actionable, I’m just leaving a link here in case it could be useful later on in this thread.

    • This reply was modified 4 months, 1 week ago by zieladam.
    • This reply was modified 4 months, 1 week ago by zieladam.
    Thread Starter ab6499

    (@ab6499)

    I tried disable gutenberg plugin, but the problem remains

    Hi @ab6499,

    Do you have the Gutenberg editor plugin installed., if not you can download the plugin.

    Then try this

    remove_theme_support( 'widgets-block-editor' );

    Follow These steps
    Under tab Appearance >> Theme Editor (Under Widgets)

    It will open the code window. On the right sidebar, you will find “Theme Functions”, Click to reach the functions in the code and paste the above code. Then save by clicking update file.

    Then you can check if your customizer starts working.

    @adriantaites87 correct me if I’m wrong, but these steps may be effectively the same as installing the Classic widgets plugin? https://wordpress.org/plugins/classic-widgets/

    Thread Starter ab6499

    (@ab6499)

    First of all thanks for the help. I didn’t understand exactly which plugin to install. Can you send me the correct link to the plugin? In the store I find many plugins called “Gutember editor …”

    Thank you very much.

    Thread Starter ab6499

    (@ab6499)

    Thanks a lot @zieladam. You solved my problem installing Classic widgets plugin.
    https://wordpress.org/plugins/classic-widgets/

    I encountered the exact same problem when WordPress updated to 5.8. I suspect this is going to be an issue for a lot of people relying on certain themes now that the 5.8 update was pushed.

    The problem is indeed solved by installing the Classic Widgets plugin. Something about a new widget feature in 5.8 is incompatible with some themes; the plugin reverts the widget functionality to status quo pre ante.

    • This reply was modified 4 months, 1 week ago by alfy40.

    hi @zieladam,

    Yes, that plugin would work the same way. However, I’m not sure about the new update 5.8. But your suggestion to the Classic Widget plugin did give us the resolution. Kudos!

    smetta

    (@smetta)

    Had the same problem with the 5.8 update. Installing and activating Classic widgets plugin fixed the issue.

    gavr1l0

    (@gavr1l0)

    Had the same problem with the 5.8 update too

    Yep, same problem, and Classic Widgets fixed it.

    BASiQ

    (@basiq)

    Came here to comment, Classic Widgets fixed it for me as well (GreenThumbs).

    Thanks a lot @zieladam. Same issue with 5.8. Classic widgets fixed it.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.