Support » Alpha/Beta/RC » 5.8-beta1 – Feedback

  • Resolved jim5471

    (@jim5471)


    Turnkey Server Linux 4.19.0-8
    WP Version 5.8-beta1
    PHP version 8.0.7

    1. Create New or Opening existing Pages (also Posts) fails to blank page with these errors

    PHP: Deprecated: block_categories is deprecated since version 5.8.0! Use block_categories_all instead. in /var/www/wordpress/wp-includes/functions.php on line 5381
    
    Javascript: SyntaxError: invalid identity escape in regular expression editor.min.js:1:3
    An error occurred while running 'mapSelect': n(...) is null data.min.js:2:20547
        Te http://www.pu3a.com/wp-includes/js/dist/data.min.js:2
        Ys http://www.pu3a.com/wp-includes/js/dist/edit-post.min.js:49
        we http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:84
        zj http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:226
        Th http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:152
        tj http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:152
        Te http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:146
        Ja http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:224
        md http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:173
        nd http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175
        Rh http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:147
        nd http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175
        render http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:238
        Js http://www.pu3a.com/wp-includes/js/dist/edit-post.min.js:49
        _wpLoadBlockEditor http://www.pu3a.com/wp-admin/post.php?post=6917&action=edit:2028
    
    TypeError: "Object(...)(...) is undefined"
        Ys http://www.pu3a.com/wp-includes/js/dist/edit-post.min.js:49
        we http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:84
        zj http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:226
        Th http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:152
        tj http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:152
        Te http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:146
        Ja http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:224
        md http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:173
        nd http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175
        Rh http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:147
        nd http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175
        render http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:238
        Js http://www.pu3a.com/wp-includes/js/dist/edit-post.min.js:49
        _wpLoadBlockEditor http://www.pu3a.com/wp-admin/post.php?post=6917&action=edit:2028
    react-dom.min.js:125:16
        Me http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:125
        callback http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:138
        Wg http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:67
        oj http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:127
        Aj http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:160
        unstable_runWithPriority React
        Da http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:60
        ab http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:154
        Te http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:146
        Ja http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:224
        md http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:173
        nd http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175
        Rh http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:147
        nd http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175
        render http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:238
        Js http://www.pu3a.com/wp-includes/js/dist/edit-post.min.js:49
        _wpLoadBlockEditor http://www.pu3a.com/wp-admin/post.php?post=6917&action=edit:2028
    
    TypeError: Object(...)(...) is undefined[Learn More] edit-post.min.js:49:129914
    
    2. Dashboard/Appearance/Widgets - fails to display anything with 2 javascript errors
    
    Error: An error occurred while running 'mapSelect': e(...) is null The error may be correlated with this previous error: K/t<@http://www.pu3a.com/wp-includes/js/dist/block-directory.min.js:2:7527 e/e<@http://www.pu3a.com/wp-includes/js/dist/data.min.js:2:20814 __experimentalMarkListeningStores@http://www.pu3a.com/wp-includes/js/dist/data.min.js:2:16749 z/</<@http://www.pu3a.com/wp-includes/js/dist/data.min.js:2:17233 Te/b<@http://www.pu3a.com/wp-includes/js/dist/data.min.js:2:20169 e@http://www.pu3a.com/wp-includes/js/dist/data.min.js:2:20808 Te/<@http://www.pu3a.com/wp-includes/js/dist/data.min.js:2:20926 Bh@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:126:456 oj@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:126:549 Aj@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:160:448 unstable_runWithPriority@http://www.pu3a.com/wp-includes/js/dist/vendor/react.min.js:25:260 Da@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:60:280 ab@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:154:190 Te@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:146:355 Ja@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:224:381 md@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:173:43 nd/<@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175:222 Rh@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:147:64 nd@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:175:208 I.render@http://www.pu3a.com/wp-includes/js/dist/vendor/react-dom.min.js:238:412 mt@http://www.pu3a.com/wp-includes/js/dist/edit-widgets.min.js:2:40049 @http://www.pu3a.com/wp-admin/widgets.php:2014:4 Original stack trace:http://www.pu3a.com/wp-includes/js/dist/data.min.js line 2
    
    SyntaxError: invalid identity escape in regular expressionhttp://www.pu3a.com/wp-includes/js/dist/editor.min.js line 1

    3. Dashboard/Appearance/Customise

    Examining one of my ‘Custom HTML’ widgets set up to show a word cloud using svg gives the message “Request-URI too long. The requested URL’s length exceeds the capacity limit for this server”.

    The widget is fully functional – the message does not make sense.

    The widget is editable if you click on the message.

    • This topic was modified 6 days, 12 hours ago by Yui.
    • This topic was modified 6 days, 12 hours ago by Yui. Reason: formatting
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter jim5471

    (@jim5471)

    I have looked again with my other browsers and have found that the javascript errors do not occur.

    The errors above are present with Firefox version 66.0.4 64bit.

    I use this version of Firefox as it allows me to use various tools whilst the later versions do not.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    šŸ³ļøā€šŸŒˆ Plugin Review Team Rep

    Seeing as that’s a 2 year old browser (5 May 2019) and the current version is 89, this is a little edge case. Out of date browsers are generally perceived as a security risk and are not supported.

    https://browsehappy.com

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.