Support » Plugin: Enable jQuery Migrate Helper » 5.7 Update and support

  • Just wondering if this plugin is going to be updated to compatibility with 5.7 when it is released in March. Heard rumor that this plugin will not be updated anymore and that would be a shame because this plugin has been an excellent tool for temporary fixes giving developers time to work through the issues experienced when jQuery is updated by WordPress.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Marius L. J.

    (@clorith)

    Hiya,

    There’s no immediate plans to keep pushing jQuery fixes into this plugin, no. Currently it’ll let you downgrade from jQuery 3.5 (bundled in WordPress core) to legacy jQuery (version 1.12), for an intermitten period.

    It should be noted that by the release of WordPress 5.7, developers would have had 8-9 months in which to update their code.

    That said, there’s nothing in this plugin that would break with a new release of WordPress either, but we may push it to be more persistent in its messages to site admins to get their sites code fixed 🙂

    So, to confirm, this plugin will still “work” to help sites use legacy versions of jQuery and/or jQuery Migrate — even after 5.7 (or 5.8, or whenever WP finally removes jQuery Migrate)?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.