Support » Fixing WordPress » 5-6 second unresponsive page after clicking links

  • kayb100

    (@kayb100)


    Hi everyone,

    The issue is: when a user clicks a store link on our site nothing happens for about 5-6 seconds, then the page loads instantly all at once.

    – The problem occurs mostly from the left navigation menu (when clicking a store link)

    – the problem is only when clicking on a ‘STORE’ pages, strangely ‘CATEGORY’ pages load fast for some reason.

    If anyone is willing to take a look please go to a store page like this http://www.ivouchercodes.sg/store/zalora/

    then click a store from the left menu (make sure to click a store not a categry), then you should see after you click a store name from the left navigation that there is a long delay in response, about 5-6 seconds.

    More info:

    – We’re using a VPS, mid range, i don’t know the exact specs unfortunately but its with big scoots, they said everything is fine at their end.

    – it’s a new site, traffic is less than 100 users per day

    – our developers have tried a few plugins to defer javascript, but unfortunately these plugins break our navigation menu, they also didn’t seem to improve page load. There was one plugin that deferred javasript loading and our site did load faster, but that also broke our header navigation, we removed (deleted) that plugin for a short period while troubleshooting and now we cant locate which plugin that was unfortunately (stupid mistake) as we tried so many different plugins.

    If anyone has any advice to offer or could take a look at our site it would be hugely appreciated. We’ve been working on this issue for the past week and we can’t seem to fix it or find out what’s causing this big delay when you click a store name.

Viewing 2 replies - 1 through 2 (of 2 total)
  • atinyrhino

    (@atinyrhino)

    Hi. Yes, 5-6 second page load time is WAY too long. I visited your site and it took about 10 seconds to load. Have you tried temporarily activating one of the default WordPress themes to see if your theme is the offender? If it’s not your theme, it might be a plugin. Have you tried disabling all of your plugins and reactivating them one a time to find the offending plugin? Often SEO plugins can bloat your website. So if I were you I’d start my search there. You could also use another plugin called “P3 Plugin performance Profiler” which shows you which plugins might be slowing down your site.

    However, if that still doesn’t solve your problem you’ll need to dig deeper and use tools to help you figure out the source of the problem. I actually work for the team at A Tiny Rhino and you can use our tools (through a free trial) to dig deeper into the cause of the problem. Using our “page speed” tool you can figure out exactly what’s causing the slow load time and we provide easy to follow actionable steps to help you fix it. Once you’re logged in go to “seo analysis” and then “page speed”. You will be told which items are “critical” and which ones are recommended fixes. For example, our system could recommend minifying CSS, HTML, compressing your website or looking for ways to fix server response times. Just go through each step until your problem is solved 🙂

    I hope this helps and I hope you can get your load speed down. Good luck!

    kayb100

    (@kayb100)

    Hi thanks for the response.

    Just so everyone knows, i found the solution.

    We use cloudflare CDN

    with W3Total cache. there was a conflict between the two. Only choose one of these to handle minify (we turn minify off in w3cache and ON in cloudflare)

    ALSO

    more importantly, we turned off object cache & database cache in w3total cache, as these were conflicting with cloudflare too, after that all was fixed (pretty much)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘5-6 second unresponsive page after clicking links’ is closed to new replies.