Support » Plugin: Post SMTP Mailer - Email Log - SMTP Connector » 5.5.1 Invalid command

  • Resolved Cyclopaat

    (@cyclopaat)


    For some reason Post SMTP is generating 5.5.1 errors since today.

    Nothing has changed as far as we know, neither in the plugin settings, nor at the SMTP host.

    Any idea – people no longer receive 2FA authentication codes, so they can’t log in.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • I have the same problem

    Hi @cyclopaat and @jola70,

    @cyclopaat – I can’t actually access the site that you have included in your post? Are you currently down?

    To try and troubleshoot the problem. Could you run a connectivity test from the plugin settings to ensure that your web hosting server is still able to see your SMTP server.

    What SMTP provider are you using?

    Kind Regards,
    Tim

    Thread Starter Cyclopaat

    (@cyclopaat)

    Yeah, sorry – it’s https://membersite.mcce-mil.org.

    SMTP was and is fine – we’re using mijndomein.nl for this site.

    Okay, great. What SMTP server do you have set up in PostSMTP?

    Did you run the connectivity test?

    Kind Regards,
    Tim

    Thread Starter Cyclopaat

    (@cyclopaat)

    It all worked for months. I take it that Post SMTP didn’t update yesterday or Wednesday, but could it be another plugin update caused this?

    I wouldn’t know which one, but I can do a trial and error with the ones that were updated. Doesn’t make sense if it’s a Post SMTP problem…

    I don’t know how to do a connectivity test – I can send a test nail, bur that results in the same ‘5.5.1 Invalid command’ error.

    I tried fail back, but I ran into Microsoft SMTP problems. Can’t see right now, but the authentication was fine, but relay was refused , or something like that.

    Hi @cyclopaat,

    Looking at the development log, no, PostSMTP has not had any updates since early August. I believe the author is very busy at the moment so has not had time to look at any updates.

    To be honest, with that type of error – I doubt that it is a plugin conflict, while it’s a possibility this is more likely to be some kind of SMTP server problem.

    To run a connectivity test, if you head into the PostSMTP settings, you should find an option to run a ‘Connectivity test’ on the right hand side. When you run that, it will show you a grid of all the servers the web hosting server can connect to and on what ports. This is really useful in debugging in order to find any possible connection problems there.

    From the error you are getting, I suspect it is more likely an issue with either the SMTP account, or credentials.

    I’m slightly confused as you now mention Microsoft SMTP – are you using Office 365 (now Microsoft 365) or are you sending your SMTP via mijndomein.nl. It’s important to know so that we can try to help you figure out the issue. This is the really important bit. 🙂

    Kind Regards,
    Tim

    Thread Starter Cyclopaat

    (@cyclopaat)

    Hi Tim,

    kay, I found that option – the only thing that would indicate an error is probably:

    ✅ 🔒 Port 587 can be used for SMTP to mail.mijndomein.nl. Warning: connected to oxcs.net instead of mijndomein.nl

    I have no idea if that was a warning that was there all along, as I have never done that test.

    If that is the problem, I wouldn’t know where to look…

    Maybe Jola70 can share his test data and see if there’s something to be made from this problem?

    Thanks for your help and I didn’t realize you were not even the developer.

    Robert

    Hi Robert,

    I don’t think that message is of concern – it certainly won’t stop SMTP connecting in this case.

    As we can see that PostSMTP can see and connect to mail.mijndomein.nl on Port 587, then we can narrow the issue down to logging into that SMTP server. Please double check the username (full email address) and password that you have set in the PostSMTP settings to ensure they are correct. Please verify these with the SMTP provider too – in case they have been accidentally changed (for example).

    I know it sounds silly re-checking the credentials, however I’ve seen this happen before so it’s worth being sure they are right. The 5.5.1 error can be generated by incorrect credentials on the SMTP server.

    Unless @jola70 is also using mail.mijndomein.nl then their issue is likely different and would be best opening a new thread about that.

    Look forward to hearing your results! 🙂

    Kind Regards,
    Tim

    Hi,
    I also have problem with mail.mijndomein.nl.
    They have neither their own servers nor e-mail. They use Amazon and other providers. The worst provider I’ve ever dealt with. And in my opinion they are the problem.
    I changed the settings to STARTTLS (I used before SSL) and it helped temporarily.
    But I already have another provider.
    Kind regards,
    Jola

    Thread Starter Cyclopaat

    (@cyclopaat)

    Hi Jola,

    Thanks, that would (probably) explain where te problem lies.

    They were not my first choice either (I always use Antagonist and they actually came up with the Post SMTP plugin to circumvent mail problems from the site), but it’s what this company picked.

    I will contact MijnDomein, but I doubt they will be helpful.

    To Tim: sorry for the SMTP confusion. I tried M365 as fall back, which is an option in the plugin and they have a M365 E3 account, but that didn’t work either.

    In the meantime, I’m using Antagonist as service now – that works.

    Thanks both!

    Robert

    Thread Starter Cyclopaat

    (@cyclopaat)

    (Forgot to close the ticket)

    Hi Robert,

    No problem – thanks for giving us an update and for marking the thread as resolved. It does indeed sound like the party at fault here is MijnDomein, so good luck!

    Please do feel free to create a new thread here should you need any further help.

    Kind Regards,
    Tim

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘5.5.1 Invalid command’ is closed to new replies.