Support » Plugin: Contact Form 7 » 5.4 spinning icon, no message, js console errors – cache plugin incompatibility

  • This issue has been reported many times on this support forum since 5.4 released, with little or no help offered, nor any acceptance by developers that CF7 5.4 has introduced an issue. Hopefully this will help with resolve this, and guide the developers to fixing it.

    The issue is definitely a conflict between cache plugins and CF7, introduced by CF7 5.4. This issue is not present in CF7 5.3.2. I use Litespeed Cache, and on a Litespeed server. The cache settings I use have worked for a long time now, with all issues ironed out – that is until now.

    The issues are:
    Spinning icon on after form submission
    No confirmation message under the form
    Javascript console errors

    I have reverted back to 5.3.2 on all my live websites until this is fixed.

    To narrow down the issue:
    Disabled plugins – the issue is with the litespeed cache and the recaptcha that calls google api. No issues or errors in CF7 5.3.2
    Turnes all back on, selectively excluded js files from combining. Minimising is fine, it’s the combine and what is deferred that is the issue.

    With recpatcha set on in CF7, and a V2 recpatcha plugin uses:
    The Litespeed Cache plugin settings that result is all messages and no errors is:
    [2] JS Settings Tab
    JS Minify – ON
    JS combine – ON
    JS external and Inline – OFF
    JS HTTP/2 Push – OFF – but its OK with it ON.
    Load JS Deferred – ON
    Load Inline JS – After Dom ready (any other setting and get errors)

    [7] Tuning Tab
    JS Excludes –
    jquery.js
    jquery.min.js
    wpcf7-recaptcha/assets/js/wpcf7-recaptcha-controls.js

    JS Deferred Excludes
    jquery.js
    jquery.min.js
    wpcf7-recaptcha/assets/js/wpcf7-recaptcha-controls.js`

    If NO recpatcha set on in CF7 or on the contact form:
    The Litespeed Cache plugin settings that result is all messages and no errors is:
    [2] JS Settings Tab
    JS Minify – ON
    JS combine – ON
    JS external and Inline – ON or OFF
    JS HTTP/2 Push – OFF – but its OK with it ON.
    Load JS Deferred – ON
    Load Inline JS – After Dom ready (as before any other setting and get errors)

    [7] Tuning Tab – no reference to cf7 recaptcha js file needed
    JS Excludes –
    jquery.js
    jquery.min.js

    JS Deferred Excludes
    jquery.js
    jquery.min.js

    So it appears that there is a change in CF7 with some inline JS introduced in CF7 5.4 that is not behaving as expected with just about any other plugin. No other plugin has required settings to be tweaked like this. It is reasonable to assume that the same issues will be seen with Autoptimise, WP total cache (Which I used to use before Litespeed), and other caching solutions that optimised JS.

    The next phase of testing is to find out the effect of these changes on Woocommerce enabled websites. For now they will remain at CF7 5.3.2.

    • This topic was modified 1 year, 2 months ago by lencw.
Viewing 7 replies - 1 through 7 (of 7 total)
  • I have the same issue as above when using contact form 7 alongside WP Fastest cache.

    Yes, that’s right. The issue is also with other cache plugins that opitmatize JS. Why is there no fix yet? The issue has clearly been reported here in the forum for 3 weeks.

    @lencw did you find a solution or workaround ? Yes we are all reporting this issue since more than 1 month now and it seems to be ignored by the dev.

    Thread Starter lencw

    (@lencw)

    @numero7 yes, using the Litespeed settings as described above. I have still not had time to look at Woocommerce sites, they are still using CF7 5.3.2.
    It’s disappointing that the CF& dev team are ignoring this post, as I have spent a lot of time trying to help with the issue – and still no fix.
    Every other post about this the dev team ask about other plugin, disabling other plugins and the usual wordpress stuff, and seem unwilling to acknowledge that they have introduced a problem that is widespread.

    @lencw thanks for the feedback… i also sent multiple support requests regarding this issue (even some of them seems to have been removed) and i came at the same conclusion… hope he will realise soon that it’s impacting thousands of websites actually.

    Hi, has anyone tested the latest version 5.4.1?

    Regards

    Hello,

    yes, since the update to 5.4.1 the contact form works again – on my blog.

    Lorenz

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘5.4 spinning icon, no message, js console errors – cache plugin incompatibility’ is closed to new replies.