Support » Fixing WordPress » 5.3 upgrade error

  • Updated our test site and received an error going from 5.2.4 to 5.3.

    I found this error mentioned here, but I can’t comment on that ticket (can’t login or no permissions):

    https://core.trac.wordpress.org/ticket/48593

    Fatal error: Class β€˜WP_Privacy_Data_Export_Requests_List_Table’ not found in /wp-admin/includes/deprecated.php on line 1526 On WordPress 5.3

    After I made the suggested changes to get back into the site, I tried to do the re-install of 5.3 and the error recurred.

    Not sure where to go from here on it, but as a test I am reloading the test site completely from a backup of our main site to try that.

Viewing 9 replies - 1 through 9 (of 9 total)
  • https://core.trac.wordpress.org/attachment/ticket/48593/mhshohel-fatalerrorfix.diff
    Applying this patch means you have to use this also with WordPress 5.3.
    each update can cancel patch changes.
    I see that I can answer the ticket: /

    The backup restored from our live site, database and content, and had the same error.

    I realize the patch would have to be applied each time, I guess my issue is wondering why it needs to be applied at all? The other comments on that ticket pointed to the idea that it was not a core problem, so how to narrow it down so that updates don’t break the site?

    @scmsteve try disabling all plugins switch to the default theme clear your cache plugin, clear your hosting cache, empty your cdn cache, clear your browser cache.
    Now use the private mode of chrome. does the problem exist now?

    On a live production site? πŸ™ On every upgrade? πŸ™ πŸ™

    I will see, but there is not a better way to find the actual cause of the error without this hunting in the dark blind disabling everything in site?

    • This reply was modified 2 months, 4 weeks ago by scmsteve.

    Hi @scmsteve

    You can narrow it down by searching for either WP_Privacy_Data_Export_Requests_List_Table or WP_Privacy_Data_Export_Requests_Table in your theme, plugins or mu-plugins.

    If you find instances of WP_Privacy_Data_Export_Requests_Table you can replace them with WP_Privacy_Data_Export_Requests_List_Table and that should address your issue.

    Or if you just find WP_Privacy_Data_Export_Requests_List_Table then please share the code for investigation.

    Thank you

    THe problem is when it is loaded in wp-admin/includes/deprecated.php. I realize this is strange, as it should (only?) be called from wp-admin/includes/admin.php which does previously include ‘class-wp-privacy-data-export-requests-list-table.php’ and ‘class-wp-privacy-data-removal-requests-list-table.php’, so these classes should be defined.

    Yet the error given by deprecated.php shows they are clearly not however it is getting loaded/called.

    BTW: Did a grep of all files in themes/plugins and those class names are not referenced.

    • This reply was modified 2 months, 4 weeks ago by scmsteve.

    Doing another grep, I found that a plugin “woocommerce-help-scout” had an include like this:

    include_once ‘includes/deprecated.php’;

    It isn’t prefixed wtih a path, and seems to somehow being triggering the wp-admin/includes/deprecated.php incorrectly.

    Disabling that plugin allows me to re-install 5.3 without retriggering the error.

    Thanks for the sleuthing @scmsteve glad to hear you’ve found the root cause there.

    As woocommerce-help-scout is a paid plugin you’ll want to use your account to open a support ticket with them to have them address the issue.

    If you need the plugin active in the meantime you might be able to comment out that include, but if that causes issues you can instead just before that call add calls to the privacy table scripts;

    
    include_once 'includes/class-wp-privacy-requests-table.php'
    include_once 'includes/class-wp-privacy-data-export-requests-list-table.php'
    include_once 'includes/class-wp-privacy-data-removal-requests-list-table.php'
    

    All the best

    • This reply was modified 2 months, 4 weeks ago by Garrett Hyder.

    I reported the problem and can confirm that at least the WooCommerce Help Scout plugin is fixed:

    2019-11-20 – version 2.2
    Fixed issue ‘WP_Privacy_Data_Export_Requests_List_Table’ with wordpress 5.3.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.