Support » Plugin: Ocean Extra » 5.3 throws an error

  • Resolved Deleyna

    (@deleyna)


    Looks like the update to 5.3 is causing an error. I had to disable Ocean Extra to even get into the admin area. Here are the errors I’m still seeing:
    ——————
    Warning: Declaration of QuietSkin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /home/–/public_html/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php on line 12

    Warning: Cannot modify header information – headers already sent by (output started at /home/–/public_html/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home/–/public_html/wp-includes/functions.php on line 5946

    Warning: Cannot modify header information – headers already sent by (output started at /home/–/public_html/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home/–/public_html/wp-admin/includes/misc.php on line 1252

    Warning: Cannot modify header information – headers already sent by (output started at /home/–/public_html/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home/–/public_html/wp-admin/admin-header.php on line 9

Viewing 15 replies - 46 through 60 (of 80 total)
  • @veso_peso Thanks. Works fine.

    @deleyna
    I still have the same problem. I already try this:

    wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:
    public function feedback($string) { /* no output */

    to
    public function feedback($string, …$args) { /* no output */

    but not help (i just install fresh WP and first instal Ocean skinn… 30 m ins ago). Still i have problem with:

    Warning: Declaration of QuietSkin::feedback($string, … $args) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /home/server045428/ftp/wp/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php on line 12

    Warning: Cannot modify header information – headers already sent by (output started at /home/server045428/ftp/wp/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home/server045428/ftp/wp/wp-includes/functions.php on line 5946

    Warning: Cannot modify header information – headers already sent by (output started at /home/server045428/ftp/wp/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home/server045428/ftp/wp/wp-admin/includes/misc.php on line 1252

    Warning: Cannot modify header information – headers already sent by (output started at /home/server045428/ftp/wp/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home/server045428/ftp/wp/wp-admin/admin-header.php on line 9

    Thank you very much, I managed to desactivate the plugin for now. And the site works (almost) perfectly like that. I’ll see tomorrow for the rest.

    Thanks again !

    I have the same problem

    Warning: Declaration of QuietSkin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /home2/crerma44/casadeesther.com/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php on line 12

    Warning: Cannot modify header information – headers already sent by (output started at /home2/crerma44/casadeesther.com/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home2/crerma44/casadeesther.com/wp-includes/functions.php on line 5946

    Warning: Cannot modify header information – headers already sent by (output started at /home2/crerma44/casadeesther.com/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home2/crerma44/casadeesther.com/wp-admin/includes/misc.php on line 1252

    Warning: Cannot modify header information – headers already sent by (output started at /home2/crerma44/casadeesther.com/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home2/crerma44/casadeesther.com/wp-admin/includes/template.php on line 1960

    Thank you @veso_peso

    @prezez3 Look at your error, though. The first one says that the line is still wrong in:
    /home/server045428/ftp/wp/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php on line 12

    so…from your server, folder wp
    folder wp-content
    folder plugins
    folder ocean-extra
    folder includes
    folder wizard
    folder classes
    file QuietSkin.php line 12 — has not been changed correctly

    The easiest solution would be to rename the ocean-extra folder to something like “hold-ocean-extra” until this is resolved.

    You do not need to reinstall the theme. You do not need to reinstall ocean-extra.

    I’m a little concerned about which line you DID change…because if you are still getting that error, you likely changed the wrong line. This is why I suggest you just rename the folder. It will disable ocean-extra…which is a pain, but the errors will go away.

    And I’m sure the plugin developer will release a patch soon. If not…we’re using the wrong theme. (kidding)

    The only thing that might cause it to still have a problem AFTER you have fixed that line would be if you have some form of caching or perhaps a duplicate cloud server somewhere that hasn’t updated????

    The fix works like a charm.

    That first error points right at the problem and @veso_peso did the research to find the solution.

    I’ve applied it on a bunch of customer sites who were using ocean-extra and they’re all fine.

    But I do purge all caches on the servers after making the change. Because…cache will get you every time if you let it…

    I disabled it and it has gone away for now.

    And it looks like the latest update fixes it. Thanks folks!!!

    @veso_peso Thank you!!

    Confirming:

    1) I saw this problem with WordPress v5.3, and
    2) latest Ocean Extra (v1.5.19) DOES fix it.

    I’m not sure if this issue is related, but since 5.3 visitors see this:

    Warning: Declaration of Mesmerize_Logo_Nav_Menu::walk($elements, $max_depth) should be compatible with Walker::walk($elements, $max_depth, …$args) in /home1/ailaunchlab/public_html/wp-content/themes/mesmerize-pro/inc/Mesmerize_Logo_Nav_Menu.php on line 102

    Warning: Declaration of Mesmerize_Logo_Page_Menu::walk($elements, $max_depth) should be compatible with Walker::walk($elements, $max_depth, …$args) in /home1/ailaunchlab/public_html/wp-content/themes/mesmerize-pro/inc/Mesmerize_Logo_Page_Menu.php on line 102

    In the edit page I also see the following:

    eader information – headers already sent by (output started at /home1/ailaunchlab/public_html/wp-content/themes/mesmerize-pro/inc/Mesmerize_Logo_Nav_Menu.php:102) in /home1/ailaunchlab/public_html/wp-includes/functions.php on line 5946

    Warning: Cannot modify header information – headers already sent by (output started at /home1/ailaunchlab/public_html/wp-content/themes/mesmerize-pro/inc/Mesmerize_Logo_Nav_Menu.php:102) in /home1/ailaunchlab/public_html/wp-admin/includes/misc.php on line 1252

    Warning: Cannot modify header information – headers already sent by (output started at /home1/ailaunchlab/public_html/wp-content/themes/mesmerize-pro/inc/Mesmerize_Logo_Nav_Menu.php:102) in /home1/ailaunchlab/public_html/wp-admin/admin-header.php on line 9

    • This reply was modified 11 months, 1 week ago by timopg11.

    Hello everyone,

    I have the same problem, but I can´t change the folder name because I don´t have WP installed. I just log-in with “www. …/wp-admin” – Main problem:

    If I write “www.baumpflegepemsl.de/wp-admin” there is no Log-In-Screen.

    Just the following WARNINGS:

    Warning: Declaration of QuietSkin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /www/htdocs/w019a49c/baumpflegepemsl.de/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php on line 12

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/w019a49c/baumpflegepemsl.de/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /www/htdocs/w019a49c/baumpflegepemsl.de/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/w019a49c/baumpflegepemsl.de/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /www/htdocs/w019a49c/baumpflegepemsl.de/wp-includes/pluggable.php on line 1268

    MANY THANKS FOR YOUR HELP. I AM LOST 🙂

    Greetings from Germany
    shizzle-sissl

    Try logging into your cPanel and renaming the ocean-extra plugin folder to say ocean-extra OLD. If that doesn’t work then rename the higher up plugin folder (/wp-content/plugins/) in the same way to plugin old which would effectively disable all your plug-ins.

    I updated the plugins and theme however When I click on updates I am getting same error and then by entering F5 the error dissappears. I will be keep waiting for the new update. or any solution for that?

    With the new update everything is working fine now

    ****IMPORTANT: to see the changes remember to clear your cache!!!!

    • This reply was modified 11 months, 1 week ago by grabadosolam.
    • This reply was modified 11 months, 1 week ago by grabadosolam.
Viewing 15 replies - 46 through 60 (of 80 total)
  • You must be logged in to reply to this topic.