Support » Plugin: Comments - wpDiscuz » 5.3.5 Impossible to comment anymore, error log details inside

  • Resolved Sabinooo

    (@sabinooo)


    Hello,

    Following a critical error between wordpress and wpdicuz (I describe it here: https://wordpress.org/support/topic/critical-error-had-to-deactivate-wpdiscuz-details-inside/ ), branch 7, I rollbacked to the prior version, 5.3.5, renaming the branch 7 plugin directory, uploading the 5.3.5 version, activating that 5.3.5 one.

    For a few minutes, comments could be added again.

    But then, no more, infinite loading without anything happening.

    Here’s the Apache error log:

    [fcgid:warn] [pid 1938:tid 140647868872448] [client 108.162.229.41:14770] mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required ‘/home/blogpaul/public_html/wp-content/plugins/wpdiscuz5.3.5/utils/ajax/wp-load.php’ (include_path=’.:/usr/share/php’) in /home/blogpaul/public_html/wp-content/plugins/wpdiscuz5.3.5/utils/ajax/wpdiscuz-ajax.php on line 13, referer: https://www.[Sorry, I’m redacting that part]
    [fcgid:warn] [pid 5532:tid 140647352755968] [client 108.162.229.41:43088] mod_fcgid: stderr: PHP Warning: require_once(/home/blogpaul/public_html/wp-content/plugins/wpdiscuz5.3.5/utils/ajax/wp-load.php): failed to open stream: No such file or directory in /home/blogpaul/public_html/wp-content/plugins/wpdiscuz5.3.5/utils/ajax/wpdiscuz-ajax.php on line 13, referer: https://www.[Sorry, I’m redacting that part]
    [fcgid:warn] [pid 5532:tid 140647352755968] [client 108.162.229.41:43088] mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required ‘/home/blogpaul/public_html/wp-content/plugins/wpdiscuz5.3.5/utils/ajax/wp-load.php’ (include_path=’.:/usr/share/php’) in /home/blogpaul/public_html/wp-content/plugins/wpdiscuz5.3.5/utils/ajax/wpdiscuz-ajax.php on line 13, referer: https://www.[Sorry, I’m redacting that part]

    Multiple occurences with the various IPs of the persons who attempted. I can still reply with comments from the administration panel, in wp-admin/edit-comments.php, but not from the field below the posts.

    Context: wordpress 5.4 branch, LAMP, PHP 7.2.31-1+0~20200514.41+debian10~1.gbpe2a56b, not a weird theme but I tested with a default theme and it was the same.
    Wp-supercache and cloudflare, but I did things properly, emptied the supercache, placed cloudflare in development mode, in following tests purged entirely the cloudflare cache, no difference.

    I really would want to have this distressing issue fixed, so, please, whatever you may feel like to see me testing, do let me know, I’ll be glad to help.

    *

    SUPER FAST EDIT WHILE I CAN STILL EDIT MY POST: I found a fix circumventing (without actually solving it) the issue!

    Enabling the option to make wpdiscuz use native wordpress Ajax functions.

    Phiew, at least, that’s a relief. But if you developers need me to try stuff for you so that the bug is fixed, I’m still open, don’t hesitate, I see it as a form of help I could give, if – no idea – you’ll care to fix an issue with a now obsolete branch. Thanks already for the great plugin!

    • This topic was modified 1 year, 3 months ago by Sabinooo.
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘5.3.5 Impossible to comment anymore, error log details inside’ is closed to new replies.