Support » Fixing WordPress » 5.1 updated now cannot access any admin pages

  • festusdog

    (@festusdog)


    ok, same problem as when 5.0 update happened (aka, see https://wordpress.org/support/topic/database-upgrade-to-5-0/page/2/)

    2 websites, hosted at 1&1, one of them has no plugins active, the other site has wordfence, and neither site will allow access to any admin pages (ie, dashboard, posts, themes, etc).

    The site itself loads fine, just when you log in, you cant go anywhere or do anything.

    ie, when you try to load dashboard, you get blank page with URL:
    website.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F

    And no, it is NOT a cache issue (browser, nor any cacheing plugins). Cookies have been deleted, too.

    Since this happened at 5.0 and required a manual database entry fix, I want to know WHY this is happening (when it never happened EVER in the 10 years previous) and HOW TO FIX IT without resorting to manual database manipulation?

    regards,
    bobby

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hello festusdog,

    There can be a possibility that the WordPress upgrade didn’t happen correctly.

    Or else it can be plugin/theme conflict with the latest WP version.

    Try deactivating them via FTP and see if that helps.

    Thanks.

    festusdog

    (@festusdog)

    No, not a theme.

    The solution was same as last time, but this is a reoccurring problem since 5.0 was released, so I require a PERMANENT FIX.

    The solution was, again, to manually update the db_version in phpMyAdmin to the version number that I find in the version.php in wp-includes directory:

    $wp_db_version = 44719;

    But honestly, this is nonsense to have to manually fix this every time a upgrade is done anymore. Why is the database NOT properly changing the db_version entry?

    So what needs to be fixed? Like I said, i don’t run plugins on one of the sites, and that one has SAME PROBLEM.

    I understand and it should not be the case that someone has to manually update the DB version.

    So maybe something is interfering or it can be some permission issue which is not allowing to get the Database update automatically.

    Try to approach one to your hosting provider if they can help here.

    Thanks.

    Moderator Marius L. J.

    (@clorith)

    Hiya,

    So it sounds like you’ve had some bad luck with updates, sorry to hear that. I will say there’s nothing known wrong, as millions of sites are updating just fine, so let’s look at other possibilities 🙂

    If you install the Health Check plugin, it has a Site Status overview which will give you a general understanding of potential problems that may prevent updates. It sounds like a potential ownership issue on some files, as you mention manual intervention is needed in some aspects, which sounds odd.

    It could also be a bad cache on the hosts side, this isn’t uncommon during updates, at least not when updating straight away, as hosts get overloaded when many sites update at once (I’ve seen other reports of this for your mentioned host, so it’s not an unlikely scenario, and it might have worked straight away a day later). To find out if that’s the case you would have to contact the host though, as they are likely running some form of caching on your site in the background, even if you’re not running anything particular your self.

    williampatton

    (@williampatton)

    Purely speculation here as I have not yet tested this but my theory here is that previous bumping of the version string directly in the database results in the database not performing the upgrade process – and then future updates fail in an unexpected way due to missing or malformed tables.

    I will try to test this exact scenario myself later today if I have tim ebut this may give an avenue to investigate.

    Also I have seen host based caching mechanisms break things between accounts on shared hosting (and yes also directly on 1&1) but never in the kind of ways described here. I don’t think that this is a host side caching issue.

    crzyhrse

    (@crzyhrse)

    following…

    festusdog

    (@festusdog)

    Hi everyone,
    thanks for working with me to eventually resolve this problem.

    Replying to a few points above:

    1) I installed Health Check, and nothing was flagged except “5.5.60-0+deb7u1-log
    – For performance and security reasons, we strongly recommend running MySQL version 5.6 or higher. ”

    Also, the filesystem permissions are all writable.

    Here is the server info:
    Server architecture Linux 3.16.0-ui18276.29-uiabi1-infong-amd64 x86_64
    Web Server Software Apache
    PHP Version 7.3.2 (Supports 64bit values)
    PHP SAPI cgi-fcgi
    PHP max input variables 5000
    PHP time limit 50000
    PHP memory limit -1
    Max input time -1
    Upload max filesize 64M
    PHP post max size 64M
    cURL Version 7.38.0 OpenSSL/1.0.1t
    SUHOSIN installed No
    Is the Imagick library available No
    htaccess rules Custom rules have been added to your htaccess file

    2) I would be happy to blame this on 1&1, and while that may prove to be true, it really seems unlikely. I have run these 2 WP installs since 2007 and even was using auto updates before they were mainstream, via wp config entry “define( ‘WP_AUTO_UPDATE_CORE’, true );”

    So, 11 years, no issues until 5.0 was released.

    Thus, that could be coincidence that 1&1 started having a new problem exactly when 5.0 was released, but it seems more likely that something else is going on.

    3) FYI – both sites are VERY LOW TRAFFIC

    4) any suggestions as to things to change, or things to check, please advise.

    festusdog

    (@festusdog)

    To be clear, the problem is not resolved. I still don’t know what is causing the database to not update properly.

    So I am looking for answers to that. Thanks in advance.

    Moderator Marius L. J.

    (@clorith)

    There’s nothing in the server info bit that indicates anything would be wrong, you’ll have to reach out to your host and ask about the caching as I suggested I think. You may also have other things going like a plugin or theme conflicting with the upgrade routines for example (you mentioned one site having no plugins, but it does have a theme I suspect). If you could provide the full debug information that would be really useful to look for a pattern or to notice things in general as well.

    festusdog

    (@festusdog)

    debug log, with sensitive info redacted:

    
    ### WordPress ###
    
    Version: 5.1
    Language: en_US
    Permalink structure: /%postname%/
    Is this site using HTTPS?: No
    Can anyone register on this site?: No
    Default comment status: closed
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.
    
    ### Installation size ###
    
    Uploads Directory: 1.51 MB
    Themes Directory: 1.38 MB
    Plugins Directory: 13.41 MB
    Database size: 2.34 MB
    Whole WordPress Directory: 57.40 MB
    Total installation size: 59.74 MB
    
    ### Active Theme ###
    
    Name: 
    Version: 
    Author: Anonymous
    Author website: Undefined
    Parent theme: Not a child theme
    Supported theme features: widgets
    
    ### Other themes (1) ###
    
    Twenty Nineteen (twentynineteen): Version 1.3 by the WordPress team
    
    ### Active Plugins (2) ###
    
    Health Check & Troubleshooting: Version 1.2.5 by The WordPress.org community
    Wordfence Security: Version 7.2.2 by Wordfence
    
    ### Inactive Plugins (2) ###
    
    WP-DBManager: Version 2.79.2 by Lester 'GaMerZ' Chan
    WP-Optimize: Version 2.2.12 by David Anderson, Ruhani Rabin, Team Updraft
    
    ### Media handling ###
    
    Active editor: WP_Image_Editor_GD
    Imagick Module Version: Imagick not available
    ImageMagick Version: Imagick not available
    GD Version: bundled (2.1.0 compatible)
    Ghostscript Version: 9.26
    
    ### Server ###
    
    Server architecture: Linux 3.16.0-ui18276.29-uiabi1-infong-amd64 x86_64
    Web Server Software: Apache
    PHP Version: 7.3.2 (Supports 64bit values)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 5000
    PHP time limit: 50000
    PHP memory limit: -1
    Max input time: -1
    Upload max filesize: 64M
    PHP post max size: 64M
    cURL Version: 7.38.0 OpenSSL/1.0.1t
    SUHOSIN installed: No
    Is the Imagick library available: No
    htaccess rules: Custom rules have been added to your htaccess file
    
    ### Database ###
    
    Extension: mysqli
    Server version: 5.5.60-0+deb7u1-log
    Client version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    Database prefix: xxxxxx_
    
    ### WordPress Constants ###
    
    ABSPATH: /homepages/13/d123456789/htdocs/xxxxxx/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined
    
    ### Filesystem Permissions ###
    
    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    
    
    Moderator Marius L. J.

    (@clorith)

    That all looks fine, I’m still holding a finger on an object cache on the host level that’s not been cleared like it should, or the clearing is delayed as I mentioned earlier, there’s no other indicators at this time.

    ok, understood. I contacted 1&1 and their support says that they have no service issues relating to WP updates, and also that they do not cache any of my sites or cache anything relating to my sites.

    So I am at a standstill….

    Been following out of curiosity, and so now this is a stab in the dark… Just occurs to me that in the distant past a couple times accessing certain areas became not possible and I wound up having to clear my local computer’s DNS cache, which solved the issue…
    See here:
    https://documentation.cpanel.net/display/CKB/How+To+Clear+Your+DNS+Cache

    Another time I remember having to reset my modem to make it clear some stuff, off for a few minutes and then on, to solve a similar issue of not being able to access an area…

    Good luck…

    @festusdog we have exactly the same problem.
    However in our logs it was showing PHP Fatal error: Out of memory (allocated 106954752) (tried to allocate 1216512 bytes)
    We upgraded from PHP 5.6 to 7.2 and changed memory limit which worked for us.

    hi

    here is what i have found, i tried all above fixes but at the end of the day one of the plugin was causing the issue, everything got back after removing that plugin.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘5.1 updated now cannot access any admin pages’ is closed to new replies.