Support » Plugin: Jetpack by WordPress.com » 5.1 turned our site completely “white”

  • Resolved Brian

    (@womensradio)


    Noticed our site at https://womenscalendar.com/ went completely “white” today… started deactivating plugins and found that all went back to normal after deactivating Jetpack.

    Hoping the next release will address whatever might’ve caused this, as we love using the plugin!

    Cheers!

    -Brian

    • This topic was modified 3 years ago by Brian.
Viewing 4 replies - 16 through 19 (of 19 total)
  • I recommend the WP Rollback plugin to everyone with this problem (like me): it adds a “Rollback” link to most active plugins in the Plugin view, so when you click on it it lets you choose wich version to downgrade to. Works great, no more FTPing or going through your panel to upload a previous version of a plugin. Disclaimer: I’m not affiliated in any way to the plugin or anything like that.

    And just by the way, I believe it’s a incompatibility with PHP 5.3.x…it’s the only constant in every report I’ve seen so far.

    Hope it helps.

    I’ve just begun migrating to a new server (running PHP 7) and, having just moved my WordPress blog to that server, I can confirm that JetPack now works as it should without turning the site white.

    However, I did run into another issue/problem. After activating the JetPack defaults, none of my images were showing.

    One of the “default” settings is described as “Speed up images and photos” and this uses a service called “Photon” which appears to use a CDN to serve your images from wp1.com. I only realised this on investigating why none of my images showed up.

    It appears that because I have hotlink protection enabled, “Photon” couldn’t grab my images to “speed” them up, so they didn’t display at all.

    As soon as I turned off “speed up images and photos”, my images were served up from my own site as they were before and everything displays properly.

    Just another one to beware of.

    I’ve been building several new sites and every time I add the Jetpack plugin, the site goes white and the error message “Oops that page can’t be found” comes up when I attempt to customize the theme.

    Once I deactivate Jetpack, all is good. On sites I built months ago, Jetpack is working fine.

    I updated to PHP 7.1 yesterday – no change as yet in Jetpack white screen.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @camfa9 Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    It would also be helpful if you could try the following, to find out more about the issue:

    First, you will want to add the following to your site’s wp-config.php file:

    
    define( 'WP_DEBUG', true );
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define( 'WP_DEBUG_DISPLAY', false );
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }
    

    Your wp-config.php file may already include a line that says “define(‘WP_DEBUG’, false);”. You can remove it, and replace it by the code above.

    Once you’ve done so, try to reproduce the error and then check the wp-content/debug.log file for errors, and paste the results in the new forum thread you will create. You can then replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Thank you!

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘5.1 turned our site completely “white”’ is closed to new replies.