Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » 5.0.1 not using pre-update cookiebanner styling

  • Resolved marketingspectrum

    (@marketingspectrum)


    I really love Complianz. Just works like a charm.
    On the 5.0 and 5.0.1 versions I do have a problem on multiple sites.

    When updating the plugin all the cookiebanner settings are lost.
    It doesn’t happen on every website. But 50% of the sites. (same config).
    Is this known & will it be fixed? If so I will hold the update.
    Otherwise I need to recreate all the banners.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor jarnovos

    (@jarnovos)

    Hi @marketingspectrum,
    Thank you for the kind words about the plugin.

    This seems to occur with certain types of databases, but we haven’t been able to reproduce it on our end. Does it concern different hosting environments/databases?

    We have improved/expanded upon the Cookie Banner settings page, so the issue is likely caused when migrating these settings.

    The best solution for now would indeed be to manually apply the desired styles once more. This should be a one-time occurrence, so you will not have to do this again afterwards.

    Hope this clarifies.
    Kind regards,
    Jarno

    Happening to me, and attempting to update it back to what it was doesn’t save. Custom CSS doesn’t work either, although arguably I could customize the CSS elsewhere outside the plugin (rather not).

    We’re on 5.0.2.1 (prob skipped a few updates). Host is WPEngine. We’re also using Avada on this site.

    Let me know what further details you want.

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @zacwine,

    Could you enable debugging? Either by installing WP Debugging or in your wpconfig.php.

    If an error relates to your database, please let me know.

    Could you also explain which settings specifically or does it default back to the “WordPress” themed banner?

    regards Aert

    Defaults to default WP theme. No errors.

    Interestingly, after loading and activating the debug plugin then deactivating it, some of the style settings work, but not all (such as bg color).

    gifart

    (@gifart)

    Hi Aert,
    I am a complete novice so the above threat goes way over my head. But I do have an issue with the cookie banner customizer. At the end the bottom half of the page is not visible so I can’t save my setting or change the button colours etc.
    What can I do?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.