Support » Plugin: Responsive Pricing Table » 5.0.1 Not compatable with php 5.3

  • Resolved MagicStick

    (@magicstick)


    For various reasons (don’t judge me) we have a site running on php 5.3. We just updated to 5.0.1 and got a fatal error on activation. Forgive me for not having the error message as we had to quickly roll back, but it was related to using the following syntax which 5.3 doesnt like

    
    // php syntax not compatible with 5.3
    $variable = [ ... ];
    
    // php syntax compatible with 5.3
    $variable = array ( ... );

    Can we fix this so your plugin is compatible with 5.3?

    Thanks for the great work!

    • This topic was modified 3 years, 10 months ago by MagicStick.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author WP Darko

    (@spwebguy)

    Hi there,

    No judgment, we do want to be as compatible as possible.

    The only issue I have here is that we are already using the latter syntax array ( ... );.

    The error message would help a lot here because I can’t figure out where in the code we are using $variable = [ ... ];.

    We’d love to make our plugin compatible with your version, we hope you can give us more information about this.

    You can reach us here: https://wpdarko.com/ask-for-support, it’s probably going to be faster.

    Thread Starter MagicStick

    (@magicstick)

    Thanks for this. Managed to hunt down. php 5.3 moaning about Syntax error on line 39 of file:

    wp-content/plugins/dk-pricr-responsive-pricing-table/inc/rpt-metaboxes-plans.php

    Plugin Author WP Darko

    (@spwebguy)

    Hi there,

    Can you start a new request on our support platform: https://wpdarko.com/ask-for-support

    I will send you a new version of the plugin, if it works, we push it to the repository today.

    Plugin Author WP Darko

    (@spwebguy)

    Hi there,

    No need to go to our support platform, we found the issue and fixed it. We tested it on your version of PHP as well as earlier ones, everything seems to be fine.

    Please download/update to version 5.0.2 and let us know if it works for you.

    Thank you!

    • This reply was modified 3 years, 10 months ago by WP Darko.
    Thread Starter MagicStick

    (@magicstick)

    Thanks mate. Working well now!

    Plugin Author WP Darko

    (@spwebguy)

    You’re welcome, thank you for your feedback.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘5.0.1 Not compatable with php 5.3’ is closed to new replies.